Highlighted
Tony Okusanya Respected Contributor.
Respected Contributor.
460 views

Disabling HTTP affects Legacy Rest Interface

Jump to solution

Hello

I have HPOO 10.60 with a Microsof SQL 2014 database. when we disable http to only allow https. we are unable to access the /PAS/services/rest interface. However the new interface /oo/rest/v2 works fine. My question is why this is happening and how to fix it as we have some systems accessing the legacy interface.

0 Likes
1 Solution

Accepted Solutions
Tony Okusanya Respected Contributor.
Respected Contributor.

Re: Disabling HTTP affects Legacy Rest Interface

Jump to solution

Thanks Andrei that worked. I have updated the steps used to disable http to include updating the management url for anyone that runs into this issue again

Disable HTTP
To disable http and use only https
1. Edit the file <Installation_Dir>\central\tomcat\conf\server.xml
2. Comment or delete the http connector definition line (shown below)
<Connector URIEncoding="UTF-8" compression="on" connectionTimeout="20000" port="80" protocol="org.apache.coyote.http11.Http11NioProtocol" redirectPort="443" server="OO"/>
3. Edit the file <Installation_Dir>\central\conf\central-wrapper.conf
4. Change the management url to the https url(as shown below)
#wrapper.java.additional.14=-Dmgmt.url=http://localhost:80/oo
wrapper.java.additional.14=-Dmgmt.url=https://localhost:443/oo

0 Likes
2 Replies
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: Disabling HTTP affects Legacy Rest Interface

Jump to solution
Did you try to put the management URL on the central wrapper conf file to Https URL and FQDN of the machine?
Andrei Vasile Truta
Tony Okusanya Respected Contributor.
Respected Contributor.

Re: Disabling HTTP affects Legacy Rest Interface

Jump to solution

Thanks Andrei that worked. I have updated the steps used to disable http to include updating the management url for anyone that runs into this issue again

Disable HTTP
To disable http and use only https
1. Edit the file <Installation_Dir>\central\tomcat\conf\server.xml
2. Comment or delete the http connector definition line (shown below)
<Connector URIEncoding="UTF-8" compression="on" connectionTimeout="20000" port="80" protocol="org.apache.coyote.http11.Http11NioProtocol" redirectPort="443" server="OO"/>
3. Edit the file <Installation_Dir>\central\conf\central-wrapper.conf
4. Change the management url to the https url(as shown below)
#wrapper.java.additional.14=-Dmgmt.url=http://localhost:80/oo
wrapper.java.additional.14=-Dmgmt.url=https://localhost:443/oo

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.