Regular Contributor.. mtthwcruz Regular Contributor..
Regular Contributor..
569 views

Error When Remote Debugging

Receving the following error when Remote Debugging:

com.iconclude.dharma.runengine.RunException: Failed to run the action! Class: com.hp.oo.execution.control.actions.navigation.NavigationActions, method: beginStepNavigation, reason: Method: beginStepNavigation was not found in class: com.hp.oo.execution.control.actions.navigation.NavigationActions
at com.iconclude.dharma.runengine.view.BeanViewBuilder.updateRunView(BeanViewBuilder.java:524)
at com.iconclude.dharma.runengine.view.DefaultRunViewFactory.updateView(DefaultRunViewFactory.java:61)
at com.iconclude.dharma.runengine.debugger.RunControlImpl.onEvent(RunControlImpl.java:236)
at com.hp.oo.studio.debugger.engine.DebugRunEventsChannelImpl.notifyListeners(DebugRunEventsChannelImpl.java:64)
at com.hp.oo.studio.debugger.engine.AbstractDebugRunEventsChannel.processFinishEvent(AbstractDebugRunEventsChannel.java:102)
at com.hp.oo.studio.debugger.engine.DebugRunEventsChannelImpl.processFinishEvent(DebugRunEventsChannelImpl.java:129)
at com.hp.oo.studio.debugger.engine.DebugRunEventsChannelImpl.fetchDebuggerEvents(DebugRunEventsChannelImpl.java:111)
at com.hp.oo.studio.debugger.engine.DebugRunEventsChannelImpl.access$200(DebugRunEventsChannelImpl.java:27)
at com.hp.oo.studio.debugger.engine.DebugRunEventsChannelImpl$EventsFetcher.run(DebugRunEventsChannelImpl.java:194)
Caused by: java.lang.Exception: Failed to run the action! Class: com.hp.oo.execution.control.actions.navigation.NavigationActions, method: beginStepNavigation, reason: Method: beginStepNavigation was not found in class: com.hp.oo.execution.control.actions.navigation.NavigationActions
... 9 more

0 Likes
2 Replies
Josue_G_OO Respected Contributor.
Respected Contributor.

Re: Error When Remote Debugging

Hi,

Quick question:  Is your studio & central on same version level ?  Example both are on 10.80 Studio & Central ? 

Regards, 

Josue Gómez
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
fog Regular Contributor.
Regular Contributor.

Re: Error When Remote Debugging

Hi Josue,

I'm experiencing the same issue while running any debug from my Studio 10.80 against using as debuggers my Central running with 10.60... Is this some known-issue?

My understanding was that different versions is expected to be supported.. and, if my memory serves me right, I recall to see some of my colleges successfully running (e.g.) Studio 10.70 --> Central 10.60

 

Thanks,

f.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.