Dondon22 Respected Contributor.
Respected Contributor.
469 views

Execution Log... InBuffer would not poll messages, because there is not enough free memory.

Hi! OO Version 10.70 running on RedHat Linux 6.2 When I check the contents of my /hpoo/central/var/logs/execution.log... i saw this: 2017-07-05 08:31:26,185 [WorkerFillBufferThread] (InBuffer.java:226) WARN - InBuffer would not poll messages, because there is not enough free memory. 2017-07-05 08:31:26,186 [WorkerFillBufferThread] (InBuffer.java:228) WARN - Trying to initiate garbage collection Despite this, my OO is running fine... is there anything that I might be missing to fine tune... I want to keep my execution log robust so I can easily debug flow executions... Thanks in advance... Rgds, Don
In IT there is no Magic, just Logic ^_^
0 Likes
4 Replies
Micro Focus Expert
Micro Focus Expert

Re: Execution Log... InBuffer would not poll messages, because there is not enough free memory.

Hi,

It is normal that on ocasion these messages show up in the execution log, however the OO operation is not impacted by them. The execution log holds events both from the flow executions and the worker events. In the case of worker events the messages may be related to regular self-maintenace of the workers (as in this case) or recovery of the workers.

In case these messages persist you could try increasing the inbuffer capacity and heap size in the wrapper.conf file of the OO component where this is happening (central or RAS). After modifying these values restart the OO service.

Regards,

Vlad

0 Likes
Dondon22 Respected Contributor.
Respected Contributor.

Re: Execution Log... InBuffer would not poll messages, because there is not enough free memory.

Thank you Vlad! I will take a note of that...
In IT there is no Magic, just Logic ^_^
0 Likes
uday1601
New Member.

Re: Execution Log... InBuffer would not poll messages, because there is not enough free memory.

Hi ,

I am facing the same issue. Not able to run the flow. I have tried increasing the heap size and restart the service. But didn't help. Any other suggestions ?

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Execution Log... InBuffer would not poll messages, because there is not enough free memory.

Hi,

As i said increase both heap and inbuffer. 

The inbuffer parameter from the wrapper.conf file should look something like this:

"wrapper.java.additional.XX=-Dcloudslang.worker.inBufferCapacity=200"

Increasing that value should fix things. For more information see the tunning guide.

Regards,

Vlad

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.