Co0kies Contributor.
Contributor.
1410 views

Failed to read artifact descriptor for com.hp.oo.sdk:oo-plugin-archetype:jar

Jump to solution

Hello. 

I am trying to generate an operations for OO, dll based,. i tried to follow the Action Developers Guide

I have created the local repo "C:\Users\tothjur\.m2" with sdk files from \Studio\Studio\sdk
"sdk-dotnet-10.60.zip" and "sdk-java-10.60.zip"

mvn archetype:crawl
- issue solved by setting proxy in settings.xml

mvn archetype:generate -DarchetypeCatalog=file://$HOME/.m2/repository

 

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate (default-cli) on project standalone-pom: archetypeCatalog 'file:\Users\tothjur\.m2\repository' is not supported anymore. Please read the plugin documentation for details. -> [Help 1]

mvn archetype:generate -DarchetypeCatalog=local

 

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate (default-cli) on project standalone-pom: The desired archetype does not exist (com.hp.oo.sdk:oo-plugin-archetype:10.60.00-RC9) -> [Help 1]

mvn -X archetype:generate -DarchetypeCatalog=local

 

...
[DEBUG] Archetype com.hp.oo.sdk:oo-plugin-archetype:10.60.00-RC9 doesn't exist org.apache.maven.archetype.downloader.DownloadException: Error downloading com.hp.oo.sdk:oo-plugin-archetype:jar:10.60.00-RC9.
...


http://repo.maven.apache.org/maven2/com/hp/ - I tried to check the repo, and there is no "oo" folder.

settings.xml file 

<?xml version="1.0" encoding="UTF-8"?>

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0" 
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
          xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">

  <localRepository>${user.home}/.m2/repository</localRepository>

  <interactiveMode>true</interactiveMode>

  <offline>false</offline>

  <pluginGroups>
  </pluginGroups>

  <proxies>
    <proxy>
      <id>optional</id>
      <active>true</active>
      <protocol>http</protocol>
      <username></username>
      <password></password>
      <host>proxy.bbn.hp.com</host>
      <port>8080</port>
      <nonProxyHosts>local.net|some.host.com</nonProxyHosts>
    </proxy>
  </proxies>

  <servers>
  </servers>

  <mirrors>
  </mirrors>

  <profiles>
  </profiles>
  
</settings>

 


Is there any more documentation?  Example or demo ? 

Thanks for help 

Juraj

0 Likes
1 Solution

Accepted Solutions
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: Failed to read artifact descriptor for com.hp.oo.sdk:oo-plugin-archetype:jar

Jump to solution

You need to take the latest SDK.

https://marketplace.microfocus.com/itom/content/oo-sdk

Let me know if it works,

 

Andrei Vasile Truta
0 Likes
2 Replies
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: Failed to read artifact descriptor for com.hp.oo.sdk:oo-plugin-archetype:jar

Jump to solution

You need to take the latest SDK.

https://marketplace.microfocus.com/itom/content/oo-sdk

Let me know if it works,

 

Andrei Vasile Truta
0 Likes
Co0kies Contributor.
Contributor.

Re: Failed to read artifact descriptor for com.hp.oo.sdk:oo-plugin-archetype:jar

Jump to solution

Yes, i was able to generate the project.

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.