vshivanna Super Contributor.
Super Contributor.
496 views

Flow not working when I used variables in the SQL query

Hi,

 

I am trying to get the data from DB using select query... But when I used variables like ${username} or some variables in the query, the flow is not working....

 

This is the query I used:

 

 

Select status from software where username=${username} and applicationname =${appname} and machinename = ${machinename}

 

When I used like this,

Select status from software where username=vinay and applicationname =adobe and machinename = testmachine..

It is working...

 

 

 

 

Labels (1)
Tags (1)
0 Likes
1 Reply
Trusted Contributor.. jarodb Trusted Contributor..
Trusted Contributor..

Re: Flow not working when I used variables in the SQL query

Surround your variables with single quotes

 

Select status from software where username='${username}' and applicationname ='${appname}' and machinename = '${machinename}'

 

 

//Actively seeking HPOO opportunities
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.