Absent Member.. WFlores Absent Member..
Absent Member..
523 views

HP OO Workflow "Start Adhoc Server Script" timeout issue.

Using HP OO 9.07

The following HP OO workflow is not taking the timeout input correctly:
"Library\Integrations\Hewlett-Packard\Server Automation\Scripts\Start Adhoc Server Script"

 

The documentation for the workflow states that the timeout is:
"timeout - The maximum number of milliseconds to wait for the job. If not specified, the default value is set to 0."

 

That timeout is not acting how the documentation is stating. It looks like if you leave the value at 0, the script times out at 60 seconds.
You can actually see in HP SA's "Jobs and Sessions" that the timeout is set to 1 minute under 'Options' if you look at the job history.

 

If putting something other than 0, (let's say 3000000 milliseconds) the script waits that long to fail or to succeed, so you'll never know the status of the job until the full 3000000 milliseconds are up.


For example (let's say the script is simply "nslookup ipaddress"
That takes a few milliseconds to run normally.
If I put in the timeout value as 30000000 in the HP OOO workflow, then instead of waiting a few milliseconds to finish, it waits the full 30000000 milliseconds before it goes to the next step. 
In HP SA, if you look a that job history, you don't see a timeout value being set under 'Options.'

 

Has anyone used this HP Workflow before, any do you have any suggestions?

 

Thanks.

Labels (2)
0 Likes
8 Replies
Absent Member.. Sussan_Z_OO Absent Member..
Absent Member..

Re: HP OO Workflow "Start Adhoc Server Script" timeout issue.

Hello WFlores,

 

I am an Operations Orchestration representative and will be researching your question with our group internally.

 

By the moment could you please check the next information:

 

>Content Pack Version

>SA version

>Integration Content pack Version

>Is the first time that happen it?

 

Waiting your answer and I will respond when I have the next step on this situation.
Kind Regards,

“Regards,
If you find this or any post useful to resolve the issue, please mark this thread as correct answer and other members can benefit with the information given
Sussan Zamora
SW Support Technical Consultant
San Jose, Costa Rica
hpe.com
Hewlett Packard Enterprise “
0 Likes
Absent Member.. WFlores Absent Member..
Absent Member..

Re: HP OO Workflow "Start Adhoc Server Script" timeout issue.

Hi,

Thanks for taking a look into this.  Here's the info you asked for below:

 

HP OO Content Pack Version:  HP 9.07

Content packs:

 

CSA-3_20
OO-9_00_12
oo9-csa-solutions-cp-3
OO-SAS-9_00-08
OO-SM-7

 

SA Version: 10.0

 

Integration Content Pack Version - where do I get this?  Is this for SA or OO?

 

This has happened all the time, we just never had run into this.  The reason we just ran into this is because we had a command last more than 60 seconds so we tried to use the timeout value in the operation and we're finding out it's not working as it's expected to.

0 Likes
Absent Member.. Sussan_Z_OO Absent Member..
Absent Member..

Re: HP OO Workflow "Start Adhoc Server Script" timeout issue.

Hello WFlores,

Thanks for your quick response and provide me the information, so I was referring with this Integration Content Pack Version - to HPOO between HPSA, but you have provided me the information and  you are fine, regarding the integration.

 

OO-SAS-9_00-08

http://support.openview.hp.com/sc/solutions/integrations.jsp?intid=247

 

Could you please tell me if this happens in Studio or Central? or both.

 

With this information I will able to continue with my researches and consult to my OO Team.

Best Regards,

 

Sussan Zamora

HPOO

 

 

 

 

 

“Regards,
If you find this or any post useful to resolve the issue, please mark this thread as correct answer and other members can benefit with the information given
Sussan Zamora
SW Support Technical Consultant
San Jose, Costa Rica
hpe.com
Hewlett Packard Enterprise “
0 Likes
Absent Member.. WFlores Absent Member..
Absent Member..

Re: HP OO Workflow "Start Adhoc Server Script" timeout issue.

Looks like it's happening on both studio and central

0 Likes
Absent Member.. Sussan_Z_OO Absent Member..
Absent Member..

Re: HP OO Workflow "Start Adhoc Server Script" timeout issue.

Hello WFlores,

Thanks for your quick reply, so please let me check if we have any guidelines in regards of your issue.

 

Thanks for you patience,

Kind Regards,

 

Sussan Zamora

HPOO

“Regards,
If you find this or any post useful to resolve the issue, please mark this thread as correct answer and other members can benefit with the information given
Sussan Zamora
SW Support Technical Consultant
San Jose, Costa Rica
hpe.com
Hewlett Packard Enterprise “
0 Likes
Absent Member.. Sussan_Z_OO Absent Member..
Absent Member..

Re: HP OO Workflow "Start Adhoc Server Script" timeout issue.

Hello WFlores,

I hope you are great today.

 

I see that you have an Operations Orchestration support ticket open for this subject. I will work in this with my co-worker Carlos.
The back-line engineer in charge to resolve the issue and then I will post the solution to this forum thread, when I have the next step in this issue I will contact you.

 

Thanks for your understanding.

Best Regards,

 

Sussan

HPOO

 

 

 

“Regards,
If you find this or any post useful to resolve the issue, please mark this thread as correct answer and other members can benefit with the information given
Sussan Zamora
SW Support Technical Consultant
San Jose, Costa Rica
hpe.com
Hewlett Packard Enterprise “
0 Likes
Absent Member.. timfry Absent Member..
Absent Member..

Re: HP OO Workflow "Start Adhoc Server Script" timeout issue.

Sussan -- did you ever post anything back to this issue?   I didn't see an update.

 

I have the same problem, and i'm running OO 9.07, also.

 

What I found, by a bit of trial and error, is that it looks like the OO flow is taking whatever the scriptTimeout value is set to in the OO flow, and dividing it by 60, as it passes it over to HPSA.     The default is apparently 60, so that's why it reflects back over in the HPSA job as "1".

 

I needed a little longer than 1 minute to run my script, so I set theOO Start Server Script object's scriptTimeout value to a constant value of 120.    Indeed, when the flow ran, it initiated a HPSA job with the timeout value of "2".

 

I also, again, through a process of trial and error, had specified the OO flow object to have scriptTimeout as 1000.    In the HPSA job that was initiated, the Options showed the timeout value as 16. so it had taken my 1000  (seconds) and divided by 60    to get a rounded down, integer value of 16 (minutes) to pass on to HPSA.

 

So, it looks like you specify the value in OO as seconds, and then it is translated to minutes as it passes things to the HPSA initiation of the script.

 

Tim Fry

0 Likes
Felipe_A_OO Absent Member.
Absent Member.

Re: HP OO Workflow "Start Adhoc Server Script" timeout issue.

Hello Tim,

 

The case my coworker Su mentions above was closed with an internal investigation opened regarding the way the time out was passed down from HPOO to HPSA that is now finished, the timeout in "Start Adhoc Server Script" operation works as stating in the documentation. Where the operation will run for as long it takes it to run, not for as long as the timeout is set.

 

It is important to us to know the version of content pack you made the test, also it seem the documentation as well the operation was updated in further releases of the cp as it was said the timeout of HPOO was milliseconds and actually as you said they are seconds then divide by 60 (MINUTES) in HP SA.

 

There was also an issue with the default timeout and a new value but it seems the HP OO experts solve it.

 

Kindly do not open old cases and please mark this close if you do not have additional questions.

 

My best

Regards,
Felipe Alvarado S|SW Technical Support Consultant.
Operation Orchestration
Hewlett-Packard (SSO Portal)


If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.