Absent Member.. Sandy21 Absent Member..
Absent Member..
1453 views

HP OO and UCMDB integration

HI All,

 

I have HP OO 9.05 and HP UCMDB 10 installed in my environment.

 

I'm trying to use the operation "Add Object" in the path Library\Integrations\HP\UCMDB.One of the input variable used is "cmdbVersion"  where it is taking the value from Selection list  and the only values available in this list are "7.0|8.0|9.0".

 

Do anyone know how to resolve this?"

 

Labels (2)
0 Likes
4 Replies
GeorgeDK Absent Member.
Absent Member.

Re: HP OO and UCMDB integration

Hello,

 

OO's content only supports uCMDB up to version 9.0. This is true even if you install the latest content pack (CP11).

 

The way to bypass this restriction is to import the uCMDB WSDL file (if one exists) and use WebServices to interact with uCMDB.

 

HTH.

 

Kind regards,

 

George.

 

George Daflidis-Kotsis

SW Support Technical Consultant.

0 Likes
Absent Member.. Sandy21 Absent Member..
Absent Member..

Re: HP OO and UCMDB integration

Hi,

 

Thanks for the repy.

 

Is there any document available regarding the WSDL file?

 

0 Likes
Highlighted
Absent Member.. omerk Absent Member..
Absent Member..

Re: HP OO and UCMDB integration

you can get the wsdl from here:

http://cmdbserver:8080/axis2/services/UcmdbService?wsdl

then you just need to import it to the repository using the web service wizard.

0 Likes
Absent Member.. Sandy21 Absent Member..
Absent Member..

Re: HP OO and UCMDB integration

Thanks a lot for the input.

 

I am getting the operations for UCMDB in OO. Im trying to use the operation "addCIsAndRelations". But im getting the error "Service not found operation terminated !!"

 

"{document=<?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header /><soapenv:Body><soapenv:Fault><faultcode>soapenv:Client</faultcode><faultstring>Service not found operation terminated !!</faultstring><detail /></soapenv:Fault></soapenv:Body></soapenv:Envelope>;documentStripped=<?xml version="1.0" encoding="UTF-8"?><Envelope><Header/><Body><Fault><faultcode>soapenv:Client</faultcode><faultstring>Service not found operation terminated !!</faultstring><detail/></Fault></Body></Envelope>;addCIsAndRelationsResponse=;comments=;FailureMessage=;TimedOut=;Result=<?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header /><soapenv:Body><soapenv:Fault><faultcode>soapenv:Client</faultcode><faultstring>Service not found operation terminated !!</faultstring><detail /></soapenv:Fault></soapenv:Body></soapenv:Envelope>;}"

 

Can you please let me know how to resolve this?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.