Respected Contributor.. bednarcm Respected Contributor..
Respected Contributor..
672 views

HPOO/SA run script as local Administrator

Hi,

 

we have integrated CSA/OO/SA to automatic deploy VM's. Everything is working properly, but there is one problem: adding Windows systems to Active Directory.

Script uses PowerShell commands and is prepared on SA. Is marked to run as Super User. Script has user password in hash.

SA agent is working on Local System account. When script is run on  this account, it fails. When is run on Administrator account, it connects Windows to domain. So we have to run  this script as Administrator account.

In OO script is starting with standard "SA Run Script" flow which uses "Start Server Script" operation. This operation has params:

targetUser

targetPassword

TargetDomain

 

I set values for this params, but after run script fails - it is ran as Local System account, not Administrator. Jobs in SA confirm it - Run as Local System.

 

I'm really new in OO/SA systems, I don't know what should I check?

OO: 9.07

SA: 10.01

 

Best regards

Labels (1)
0 Likes
1 Reply
Respected Contributor.. bednarcm Respected Contributor..
Respected Contributor..

Re: HPOO/SA run script as local Administrator

Ok, I got it. As I wrote, I'm new here.

OO flows are imported to CSA. All flows except mine. After import this flow everything is working properly.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.