PawanKT Absent Member.
Absent Member.
572 views

HPOO SDK could not find artifact descriptor

Jump to solution

Hello,

Can any one help on this. While running maven clean install getting following error.. any directory change of sdk jar or pom file required??

[ERROR] Plugin com.hp.oo.sdk:oo-action-plugin-maven-plugin:10.20.8 or one of its
 dependencies could not be resolved: Failed to read artifact descriptor for com.
hp.oo.sdk:oo-action-plugin-maven-plugin:jar:10.20.8: Could not find artifact com
.hp.oo.dotnet:dotnet:pom:102.3 in central (http://repo.maven.apache.org/maven2)
-> [Help 1]

 

Thank you..

Labels (1)
0 Likes
1 Solution

Accepted Solutions
PawanKT Absent Member.
Absent Member.

Re: HPOO SDK could not find artifact descriptor

Jump to solution

Issue sorted by adjusting pom file.

0 Likes
4 Replies
PawanKT Absent Member.
Absent Member.

Re: HPOO SDK could not find artifact descriptor

Jump to solution

Issue sorted by adjusting pom file.

0 Likes
CEPIX Absent Member.
Absent Member.

Re: HPOO SDK could not find artifact descriptor

Jump to solution

Hi Pawan,

I'm having similar issues while trying to build maven project. "Error resolving project artifact: Failure to find com.hp.score.sdk:score-content-sdk:pom:1.3" You can see the full error log attached.

...Can you share the solution and the pom.xml?

Also your maven and jdk version would be useful for troubleshooting since I was told there are compatibility issues.

Thanks in advanced

 

0 Likes
PawanKT Absent Member.
Absent Member.

Re: HPOO SDK could not find artifact descriptor

Jump to solution

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>

<groupId>NMOOTEST_GROUP</groupId>
<artifactId>NMOOTEST_ART</artifactId>
<version>1.0.1</version>
<packaging>pom</packaging>

<name>OO sample content project</name>
<url>http://www.hp.com</url>

<properties>
<sdk.group>com.hp.oo.sdk</sdk.group>
<sdk.version>10.20.8</sdk.version>
</properties>

<build>
<plugins>
<plugin>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.1</version>
</plugin>
</plugins>
</build>

<modules>
<module>NMOOTEST_ART-plugin</module>
<module>NMOOTEST_ART-cp</module>
</modules>
</project>

0 Likes
PawanKT Absent Member.
Absent Member.

Re: HPOO SDK could not find artifact descriptor

Jump to solution

Above is my proj pom, following sdk pom..

 

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>

<parent>
<groupId>com.hp.oo.sdk</groupId>
<artifactId>sdk</artifactId>
<version>10.20.8</version>
</parent>

<artifactId>oo-sdk</artifactId>

<dependencies>
<dependency>
<groupId>com.hp.score.sdk</groupId>
<artifactId>score-content-sdk</artifactId>
</dependency>
</dependencies>
</project>

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.