Suryanarayana1 Absent Member.
Absent Member.
538 views

HPOO Soap UI testing the workflow-authenticated error

Jump to solution

Hi Team,

I am getting error when i try to run the flow inn soap ui using runFlow method.

Request:

<soapenv:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsc="http://wscentralservice.services.dharma.iconclude.com" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">
<soapenv:Header/>
<soapenv:Body>
<wsc:runFlow soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<params xsi:type="soap:WSRunParameters" xmlns:soap="http://iconclude.com/webservices/rss/v2.0/soap">
<async xsi:type="xsd:boolean">false</async>
<flowInputs xsi:type="wsc:ArrayOf_tns1_WSFlowInput" soapenc:arrayType="soap:WSFlowInput[]" xmlns:wsc="http://localhost:8080/PAS/services/WSCentralService">******</flowInputs>
<!--Optional:-->
<runName xsi:type="xsd:string">ping</runName>
<startPaused xsi:type="xsd:boolean">false</startPaused>
<trackStatus xsi:type="xsd:boolean">false</trackStatus>
<uuid xsi:type="xsd:string">8611e24e-52e7-4096-8cbe-834ba69d47af</uuid>
</params>
</wsc:runFlow>
</soapenv:Body>
</soapenv:Envelope>

 

Response:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<soapenv:Body>
<soapenv:Fault>
<faultcode xmlns:ns1="http://xml.apache.org/axis/">ns1:Authentication</faultcode>
<faultstring>Failure: User was not authenticated. Please see log file for details.</faultstring>
<detail>
<ns2:hostname xmlns:ns2="http://xml.apache.org/axis/">LabVM-34a</ns2:hostname>
</detail>
</soapenv:Fault>
</soapenv:Body>
</soapenv:Envelope>

Could any one help me on this please.i have checked in all the docs regards same but no luck.

 

Thanks,

Surya.

Labels (1)
0 Likes
1 Solution

Accepted Solutions
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: HPOO Soap UI testing the workflow-authenticated error

Jump to solution

Try to follow the attached screenshots.

They might help.

Screenshot_17.pngScreenshot_16.png

Andrei Vasile Truta
0 Likes
1 Reply
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: HPOO Soap UI testing the workflow-authenticated error

Jump to solution

Try to follow the attached screenshots.

They might help.

Screenshot_17.pngScreenshot_16.png

Andrei Vasile Truta
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.