Absent Member.. GaryDAtOrion Absent Member..
Absent Member..
130 views

HPOO troubleshooting with MATRIX

Jump to solution

Is there a guide to troubleshooting HPOO flows with MATRIX?  I need to know how to locate a flow history including what the error was when run from MATRIX.  MATRIX basically just fails with little or no explanation of why it failed.

 

My flow uses XML, which I did debug by reading the file MATRIX creates and then running a remote command.  That part works perfectly, the remote command does what it needs to do.  When I run the flow from MATRIX (which I captured the XML in a file from) it seems like the flow is failing authentication in the remote command.  I don't know how exactly to see that authentication failure.

 

Summary: I got a flow working independent of MATRIX but when I run it from MATRIX the same flow fails.

 

Since my post I drilled down through reports and found the below.  Note that I'm using a system account for the login, and it works if I don't use Matrix:

 

The error for the step says:

{Result= ;returnResult= ;stdErr=;returnCode=-1;sessionId=iconclude3437240768269989140;exception=System.Management.ManagementException: Access denied at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode) at System.Management.ManagementScope.InitializeGuts(Object o) at System.Management.ManagementScope.Initialize() at dotNET_Commons.WMI.WMISearch(String strHost, String strNameSpace, String strQuery, String strUser, String strPass, ImpersonationLevel il, AuthenticationLevel al, String locale) at dotNET_Commons.WMI.WMISearch(String strHost, String strNameSpace, String strQuery, String strUser, String strPass) at dotNETWebActions_RemoteExecution.RemoteExecution.Execute(ActionRequest req, ISession s, IActionRegistry reg);stdOut=;}

 

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Absent Member.. Sussan_Z_OO Absent Member..
Absent Member..

Re: HPOO troubleshooting with MATRIX

Jump to solution

Hello Gary,

Regarding your issue I found some information, please take a look:

 

 

RCE works by calling WMI to process the command on the remote host.  An IPC connection is then made to the box with the value specified or by default to the Admin share.

This means that by default the command runs in the context of the WMI service which is LocalSystem.  LocalSystem cannot access remote resources.  In 9.x a hidden input was added that allows delegation/impersonation.  To use it add a Input to the RCE operation called useDelegation.  This accepts boolean inputs true/false.  If set to true the operation will attempt to create a process under WMI as the user specified in the operation.  In 9.0x.03 the behavior was changed and impersonation/delegation is always attempted.

 

You can find this information in the next link: http://support.openview.hp.com/selfsolve/document/KM1027532

I hope this answer help you,

 

Kind Regards,

Sussan

“Regards,
If you find this or any post useful to resolve the issue, please mark this thread as correct answer and other members can benefit with the information given
Sussan Zamora
SW Support Technical Consultant
San Jose, Costa Rica
hpe.com
Hewlett Packard Enterprise “
0 Likes
2 Replies
Absent Member.. Sussan_Z_OO Absent Member..
Absent Member..

Re: HPOO troubleshooting with MATRIX

Jump to solution

Hello Gary,

I am an OO Team representative and will be researching your question with our group internally.  I will respond when I have more data.

 

Mean time,  Would you mind tell me the next information:

 

* HPOO version?

*Is issue the first time happen?

 

Kind Regards,

sussan

“Regards,
If you find this or any post useful to resolve the issue, please mark this thread as correct answer and other members can benefit with the information given
Sussan Zamora
SW Support Technical Consultant
San Jose, Costa Rica
hpe.com
Hewlett Packard Enterprise “
0 Likes
Absent Member.. Sussan_Z_OO Absent Member..
Absent Member..

Re: HPOO troubleshooting with MATRIX

Jump to solution

Hello Gary,

Regarding your issue I found some information, please take a look:

 

 

RCE works by calling WMI to process the command on the remote host.  An IPC connection is then made to the box with the value specified or by default to the Admin share.

This means that by default the command runs in the context of the WMI service which is LocalSystem.  LocalSystem cannot access remote resources.  In 9.x a hidden input was added that allows delegation/impersonation.  To use it add a Input to the RCE operation called useDelegation.  This accepts boolean inputs true/false.  If set to true the operation will attempt to create a process under WMI as the user specified in the operation.  In 9.0x.03 the behavior was changed and impersonation/delegation is always attempted.

 

You can find this information in the next link: http://support.openview.hp.com/selfsolve/document/KM1027532

I hope this answer help you,

 

Kind Regards,

Sussan

“Regards,
If you find this or any post useful to resolve the issue, please mark this thread as correct answer and other members can benefit with the information given
Sussan Zamora
SW Support Technical Consultant
San Jose, Costa Rica
hpe.com
Hewlett Packard Enterprise “
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.