Mirek1 Absent Member.
Absent Member.
1116 views

HPOO v10.6 User authentication in studio

Jump to solution

Hello,

is it possible to enable user authentication in studio like in oo Central (System Configuration -> Security Settings -> Enable Authentication)?

Thank you.

Labels (1)
0 Likes
1 Solution

Accepted Solutions
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: HPOO v10.6 User authentication in studio

Jump to solution

No. Studio is not coupled to anything.

However if you do remote debugging = target a central to run flows from studio: authentication and authorization will occur with that Central.

Why do you need authentication in studio?

 

 

 

Andrei Vasile Truta
0 Likes
6 Replies
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: HPOO v10.6 User authentication in studio

Jump to solution

No. Studio is not coupled to anything.

However if you do remote debugging = target a central to run flows from studio: authentication and authorization will occur with that Central.

Why do you need authentication in studio?

 

 

 

Andrei Vasile Truta
0 Likes
Mirek1 Absent Member.
Absent Member.

Re: HPOO v10.6 User authentication in studio

Jump to solution

Hi Andrei,

thanks for quick reply. I migrated some flows from v9.07 and one importnant flow is executing vbs script for windows user creation. User name for this user is generated based on current hpoo user ${execution_userid}. But now I get user name like a "anonymousUser100100073" which is invalid for windows sevrer 2012R2.

0 Likes
Mirek1 Absent Member.
Absent Member.

Re: HPOO v10.6 User authentication in studio

Jump to solution

Hi Andrei,

thanks for help. I checked old HPOO version where is not a Local connection like in new version, but "Debug Flow In Central". So I created remote debugging to oo Central (https://host:port/oo) and checked "Always promt for credentionas when authentication is enable" (which is enabled in oo Central). My flow is still not working properly, but user name is generated correctly.

Thank you.

EASJosh Respected Contributor.
Respected Contributor.

Re: HPOO v10.6 User authentication in studio

Jump to solution

Hi Mirek,

You stated that "my flow is still not working properly". Can you advise on the remaining issues?

Cheers,
Josh


--------------------------------------
If my post helped you, please click the 'Kudos' button.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: HPOO v10.6 User authentication in studio

Jump to solution

Hi,

In OO 10.6 (and newer) the use of logged in user credentials in central has 2 modes of operation:

-  it populates the username with the central username and prompts for the password

- it populates both the username and password with the central user's credentials.

In order to activate the second mode in central's system configuration workspace under  Security Settings enable the option "Enable Capture of Logged-in User credentials".

 

this should work correctly for both Central executions and remote debug.

Regards,

Vlad

0 Likes
Mirek1 Absent Member.
Absent Member.

Re: HPOO v10.6 User authentication in studio

Jump to solution

Hello Josh,

I described my issue in this topic:

/t5/Operations-Orchestration/HPOO-v10-6-VBS-Script-execution-problem/td-p/6938605

In short. I need to execute vbs script which create new local windows user. The problem is, that windows server 2012R2 uses UAC, so HPOO has not enought rights for this action. Everything works fine, when UAC is disabled. Unfortunately, it is against policy....So I tried to modify vbs script with function Function RunAsAdmin() (described in HPOO-v10-6-VBS-Script-execution-problem) - in version 9.07 it works fine. The problem is, that is not possible to add "run as administrator" directly to cmd.exe, only to its shortcut.

I will be very glad for any help.

 

Mirek

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.