Absent Member.. DBR Absent Member..
Absent Member..
194 views

I am trying to configure authentication using AD LDAP in 10.10

I have read all of the documentation and it is not clear enough.  I have opened ticket # 4648809746 and still no help.  This is what I am looking for.  This is what I am looking for.

 

HPOO 9.0x

HPOO 10.10

LDAP URL

Host/Port

List of LDAP contexts containing user groups. For example, if you have a "Groups" object containing groups of users, then the expression: ou=Groups,dc=mycompany,dc=com might be used. The list separator is a ";".

 

LDAP search filter that tries to match the user groups (see RFC 2254 for LDAP search filter syntax). This filter is applied to the discovered groups and if it matches, the user is considered part of that group.

 

List of LDAP contexts containing users. {0} denotes the location where the username should be inserted to create a DistiguishedName. The list separator is a ";".

 

LDAP search filter used in the user search (see RFC 2254 for LDAP search filter syntax). {0} denotes the username.

 

An internal OO account representing a user that has search capabilities under AD/LDAP. The username should be a user DN: CN=user,OU=Users,DC=MyCompany,DC=ad.

Privileged User Name/Privileged User Password

AD Domain (Only used when LDAP Configuration is a Microsoft AD)

Domain

 

What do the other HPOO 9.0x settings map to in HPOO 10?

 

Thanks,

Don

 

Labels (2)
0 Likes
3 Replies
Micro Focus Expert
Micro Focus Expert

Re: I am trying to configure authentication using AD LDAP in 10.10

Don,

 

The engine in 10. x is not the same as in 9.x and they no longer map one for one.  How the IDs and groups are found etc again no longer use the same calls in 9.x.  I would disregard thinking about how it was done with 9.x and think only of the questions asked in 10.x and work with your AD admin and through the ticket to get them filled out.

 

Regards,

0 Likes
Established Member.. DaisyHP567
Established Member..

Re: I am trying to configure authentication using AD LDAP in 10.10

On my initial attempt at upgrading OO 9.x, the LDAP info was taken into the OO 10 configs, and it worked fine. That was using an older LDAP, so when I changed the settings to point to a newer LDAP, I couldn't get it to work.

According to the HPOO install guide, if you are keeping the same LDAP and doing an upgrade, you should be able to run the upgrade and the existing LDAP settings will work (providing you put in the right certificates to the new OO keystores).

Has anyone gotten the LDAP in v10.x to work with their LDAP?
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: I am trying to configure authentication using AD LDAP in 10.10

Yes,

 

Many times - Daisy If you havent and are having issue please open a ticket and support will help resolve it.

 

As to 9.x correct it imports ONE config - and Its as custom -vs in 10.10 you would pick the type of LDAP you need like AD/Sun/etc.  In 10.10 to put in a new instance there are templates to help simplify .  Its much simpler in 10.10 in most cases you should have to change almost nothing and fill in only one or two fields.

 

Regards,

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.