FranciscoLeiria Trusted Contributor.
Trusted Contributor.
670 views

Multi Instance (multi lane) flows not Completing

Hello team

I have the followig issue:

Flows with parallel execution (multi-lanes) does not progress. (each individual lane complete, but the flow never progresses from there).

Tried modifying the worker threads/heap size, etc... But is working on another environments with same configuration. I saw a same issue rised here years ago but with no final known resolution.

Any clue?

OO is 10.80 upgraded from 10.60

Thank you,

Francisco

0 Likes
7 Replies
FranciscoLeiria Trusted Contributor.
Trusted Contributor.

Re: Multi Instance (multi lane) flows not Completing

00 is 10.80 running on windows 2008 R2

DB is SQL 2012

Found similar issue in the forum
https://community.softwaregrp.com/t5/Operations-Orchestration-User/Multi-Instance-Flows-not-Completing/m-p/826725#M5478

But no resolution was shown.

0 Likes
Outstanding Contributor.. JarodMB Outstanding Contributor..
Outstanding Contributor..

Re: Multi Instance (multi lane) flows not Completing

Do you have other MI steps in the env with the same issue?

Take a look at /oo/monitoring
Jobs section toward bottom - (split join trigger) delays in processing/ too long to process/ triggering too frequently?

Can you advise number of records per OO_EXECUTION* tables

0 Likes
FranciscoLeiria Trusted Contributor.
Trusted Contributor.

Re: Multi Instance (multi lane) flows not Completing

Thank  you for your reply.

Do you have other MI steps in the env with the same issue?

YES. All flows with MI on this environment fails the same, even a test with onky that

- /oo/monitoring (See attached) at the moment the split were completed (each lane)

- OO_EXECUTION* table ?

See tables on attached pic. Which table do you mean?

 

Thanks again for your reply

 

0 Likes
Outstanding Contributor.. JarodMB Outstanding Contributor..
Outstanding Contributor..

Re: Multi Instance (multi lane) flows not Completing

I mean the number of records per table -> can you screenshot (In SSMS Right click DB -> Reports -> Disk Usage by Table) for that section of tables.

Also, I don't see the attachment for /oo/monitoring jobs section

0 Likes
Outstanding Contributor.. JarodMB Outstanding Contributor..
Outstanding Contributor..

Re: Multi Instance (multi lane) flows not Completing

I haven't heard back

You could always try to clear the execution data stores - disable scheduled jobs, stop central, execute below, start central (you don't necessarily have to stop central) -- this will remove all running jobs -- you should allow previously running jobs to finish unless you don't care about their execution...

TRUNCATE TABLE OO_FINISHED_BRANCHES
GO
TRUNCATE TABLE OO_EXECUTION_INTERRUPTS
GO

DELETE FROM OO_SUSPENDED_EXECUTIONS
GO

TRUNCATE TABLE OO_EXECUTION_QUEUES 
GO
TRUNCATE TABLE OO_EXECUTED_FLOW_GRAPH
GO

TRUNCATE TABLE OO_EXECUTION_STATE
GO

TRUNCATE TABLE OO_EXECUTION_STATES
GO

TRUNCATE TABLE OO_EXECUTION_STATES_1
GO

TRUNCATE TABLE OO_PAUSE_DATA
GO

DELETE FROM OO_RUNTIME_VALUE_STORE
GO

UPDATE OO_EXECUTION_SUMMARY SET STATUS = 'CANCELED' , END_TIME=START_TIME WHERE STATUS IN ('RUNNING','PAUSED','PENDING_PAUSE','PENDING_CANCEL')

0 Likes
FranciscoLeiria Trusted Contributor.
Trusted Contributor.

Re: Multi Instance (multi lane) flows not Completing

Thank you for your reply, I didn't find your response until today.

Below the tables. I was also able to run the queries you suggested against the SQL. I stopped Central, ran the queries and startes again after deleting also the Tomcat temp files .../Central/Tomat/Temp ....  And the same result, all multi-lane flows completes the multi-step operation and just sit there. See also below the screen capture for the "jobs" under /monitoring.

The one I modified is still in the same date and time I did the modification in. 

Do you have any other suggestion?

Thank you,

Francisco

TABLE01.JPGTABLE02.JPGTABLE03.JPGTABLE04.JPGTABLE05.JPGJOBS.JPG

0 Likes
Outstanding Contributor.. JarodMB Outstanding Contributor..
Outstanding Contributor..

Re: Multi Instance (multi lane) flows not Completing

Yes, some of your jobs are running way too frequently

Did you compare the values with the other environment these MI steps are successfully executing in? 
are you seeing any errors in the central logs?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.