Dondon22 Respected Contributor.
Respected Contributor.
827 views

OO 10.70 - JVM Not Responding How to recover?

Hi!

SCENE 1: Unable to see central login page so I checked what was going on:

I got this message from wrapper.log:

INFO   | jvm 1    | 2018/03/28 09:52:54 | Mar 28, 2018 9:52:54 AM org.apache.coyote.AbstractProtocol start
INFO   | jvm 1    | 2018/03/28 09:52:54 | INFO: Starting ProtocolHandler ["http-nio-8443"]
INFO   | jvm 1    | 2018/03/28 09:52:54 | Mar 28, 2018 9:52:54 AM org.apache.catalina.startup.Catalina start
INFO   | jvm 1    | 2018/03/28 09:52:54 | INFO: Server startup in 185616 ms

STATUS | wrapper  | 2018/04/08 08:05:10 | Pinging the JVM took 37 seconds to respond.
STATUS | wrapper  | 2018/04/08 08:11:09 | Pinging the JVM took 50 seconds to respond.
STATUS | wrapper  | 2018/04/08 08:11:09 | Pinging the JVM took 41 seconds to respond.
STATUS | wrapper  | 2018/04/08 08:11:09 | Pinging the JVM took 32 seconds to respond.
... never ending prompt

Central was inaccessible... so I decided to restart central

SCENE 2: Saw the same message again while staring central... unable to start the app 😞

INFO   | jvm 2    | 2018/04/08 08:59:10 |           META-INF/database/root.changes.xml : DBMS Precondition failed: expected mysql, got oracle
INFO   | jvm 2    | 2018/04/08 08:59:10 |
INFO   | jvm 2    | 2018/04/08 08:59:10 | INFO 4/8/18 8:59 AM: liquibase: Successfully released change log lock
INFO   | jvm 2    | 2018/04/08 08:59:10 | Apr 08, 2018 8:59:10 AM org.apache.catalina.core.ApplicationContext log
INFO   | jvm 2    | 2018/04/08 08:59:10 | INFO: Initializing Spring root WebApplicationContext
INFO   | jvm 2    | 2018/04/08 08:59:23 | Database name is: Oracle databaseMajorVersion is: 12
INFO   | jvm 2    | 2018/04/08 09:00:10 | Apr 08, 2018 9:00:10 AM org.apache.catalina.core.ApplicationContext log
INFO   | jvm 2    | 2018/04/08 09:00:10 | INFO: Initializing Spring FrameworkServlet 'rest'
INFO   | jvm 2    | 2018/04/08 09:00:19 | Apr 08, 2018 9:00:19 AM org.apache.catalina.core.ApplicationContext log
INFO   | jvm 2    | 2018/04/08 09:00:19 | INFO: Initializing Spring FrameworkServlet 'reports'
INFO   | jvm 2    | 2018/04/08 09:00:20 | Apr 08, 2018 9:00:20 AM org.apache.catalina.core.ApplicationContext log
INFO   | jvm 2    | 2018/04/08 09:00:20 | INFO: Initializing Spring FrameworkServlet 'central-remoting'
INFO   | jvm 2    | 2018/04/08 09:00:26 | Apr 08, 2018 9:00:26 AM org.apache.catalina.core.ApplicationContext log
INFO   | jvm 2    | 2018/04/08 09:00:26 | INFO: Initializing Spring FrameworkServlet 'm2'
INFO   | jvm 2    | 2018/04/08 09:00:34 | Apr 08, 2018 9:00:34 AM org.apache.catalina.core.ApplicationContext log
INFO   | jvm 2    | 2018/04/08 09:00:34 | INFO: Initializing Spring FrameworkServlet 'backwards-compatibility'
INFO   | jvm 2    | 2018/04/08 09:00:34 | Apr 08, 2018 9:00:34 AM org.apache.catalina.core.ApplicationContext log
INFO   | jvm 2    | 2018/04/08 09:00:34 | INFO: Initializing Spring FrameworkServlet 'login'
INFO   | jvm 2    | 2018/04/08 09:00:35 | Apr 08, 2018 9:00:35 AM org.apache.catalina.startup.HostConfig deployWAR
INFO   | jvm 2    | 2018/04/08 09:00:35 | INFO: Deployment of web application archive /hpoo/central/tomcat/webapps/oo.war has finished in 128,327 ms
INFO   | jvm 2    | 2018/04/08 09:00:35 | Apr 08, 2018 9:00:35 AM org.apache.catalina.startup.HostConfig deployWAR
INFO   | jvm 2    | 2018/04/08 09:00:35 | INFO: Deploying web application archive /hpoo/central/tomcat/webapps/online-help.war
INFO   | jvm 2    | 2018/04/08 09:00:38 | Apr 08, 2018 9:00:37 AM org.apache.jasper.servlet.TldScanner scanJars
INFO   | jvm 2    | 2018/04/08 09:00:38 | INFO: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list                   of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
INFO   | jvm 2    | 2018/04/08 09:00:38 | Apr 08, 2018 9:00:37 AM org.apache.catalina.startup.HostConfig deployWAR
INFO   | jvm 2    | 2018/04/08 09:00:38 | INFO: Deployment of web application archive /hpoo/central/tomcat/webapps/online-help.war has finished in 2,183 ms
INFO   | jvm 2    | 2018/04/08 09:00:38 | Apr 08, 2018 9:00:38 AM org.apache.catalina.startup.HostConfig deployWAR
INFO   | jvm 2    | 2018/04/08 09:00:38 | INFO: Deploying web application archive /hpoo/central/tomcat/webapps/PAS.war
STATUS | wrapper  | 2018/04/08 09:03:10 | Pinging the JVM took 34 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:04:05 | Pinging the JVM took 52 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:04:05 | Pinging the JVM took 43 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:04:05 | Pinging the JVM took 34 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:04:52 | Pinging the JVM took 45 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:04:52 | Pinging the JVM took 36 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:05:41 | Pinging the JVM took 48 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:05:41 | Pinging the JVM took 39 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:06:33 | Pinging the JVM took 45 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:06:33 | Pinging the JVM took 36 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:07:25 | Pinging the JVM took 52 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:07:25 | Pinging the JVM took 43 seconds to respond.
STATUS | wrapper  | 2018/04/08 09:07:25 | Pinging the JVM took 34 seconds to respond.

How to recover from this? I need advise.... thank you in advance...

Rgds, Don

In IT there is no Magic, just Logic ^_^
0 Likes
2 Replies
Outstanding Contributor.. JarodMB Outstanding Contributor..
Outstanding Contributor..

Re: OO 10.70 - JVM Not Responding How to recover?

Stop the central service

clean out the tomcat cache (delete files and folders under ("central/tomcat/temp/"))
make sure database change lock isnt locked
DATAABASECHANGELOGLOCK table should have
header: id,locked,lockgranted,lockedby
values: 1,0,NULL,NULL

Start the central service

If it is still failing - does central need additional memory, additional disk space, or is garbage collection misconfigured. 

Dondon22 Respected Contributor.
Respected Contributor.

Re: OO 10.70 - JVM Not Responding How to recover?

Thanks for the response, but my problem was solved in doing some data cleansing but we tried your solution as well...

In IT there is no Magic, just Logic ^_^
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.