Dondon22 Respected Contributor.
Respected Contributor.
702 views

OO 10.70 - Purge Debugger Events Not Purging Entirely even though lastXDays = 0

Hi!

OO 10.70

I noticed the my Purge Debugger Events, not clearing up my OO_DEBUGGER_EVENTS table entirely even though I set my lastXDays input param to 0... However, I get some results though like small amount of records deleted (e.g. 12, 2, 1)...
Here are my other settings: maxAmount = 100000 ; delayBetweenRequests = 15

Any advise? because I noticed my Database Consumption in Central keeps on increasing from time to time even though I scheduled my purge flows to run every 15 minutes for Execution and 30 minutes for Debugger...

Thanks in advance...

Dondon

 

 

In IT there is no Magic, just Logic ^_^
0 Likes
6 Replies
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: OO 10.70 - Purge Debugger Events Not Purging Entirely even though lastXDays = 0

My suggestion would be to open a support ticket in order for this aspect to be properly tracked and investigated.

It might be the case that those entries are linked with some awkwardly unfinished runs.

let us know if you manage to find the root cause through a ticket.

hope it helps,

Andrei Vasile Truta
Trusted Contributor.. cheikh Trusted Contributor..
Trusted Contributor..

Re: OO 10.70 - Purge Debugger Events Not Purging Entirely even though lastXDays = 0

Hello,

Did you found a solution? I have the same problem.

Thanks in advance.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: OO 10.70 - Purge Debugger Events Not Purging Entirely even though lastXDays = 0

If the flow is returning -1 for records being deleted, it's probably because a previous run was canceled before it was finished, or because two instances of the flow were executed at the same time..

The fix for me was to log into the database and clear the row that represented the lock, per:

DELETE FROM OO_TABLE_LOCKS WHERE NAME = 'PURGE_ALL';
-- then commit, depending on the DB platform...
COMMIT;

 

0 Likes
Trusted Contributor.. cheikh Trusted Contributor..
Trusted Contributor..

Re: OO 10.70 - Purge Debugger Events Not Purging Entirely even though lastXDays = 0

The flow  is returning the number of deleted records, but nothing is being deleted since when I check the “database health” , the amount of  “debugger usage” remains the same.

0 Likes
Dondon22 Respected Contributor.
Respected Contributor.

Re: OO 10.70 - Purge Debugger Events Not Purging Entirely even though lastXDays = 0

1. Stop Central and Backup your DB.

2. Execute these query to make sure no flows are in running/pending state:

UPDATE OO_EXECUTION_SUMMARY SET STATUS = 'CANCELED', END_TIME=START_TIME WHERE STATUS IN ('RUNNING','PAUSED','PENDING_PAUSE','PENDING_CANCEL');

 

3. Purge Debugger Events

TRUNCATE TABLE OO_DEBUGGER_EVENTS;

In IT there is no Magic, just Logic ^_^
0 Likes
RaphAlv Respected Contributor.
Respected Contributor.

Re: OO 10.70 - Purge Debugger Events Not Purging Entirely even though lastXDays = 0

Hi Don
thanks for sharing this info.
just run the 'purge execution summary' and within less a minute it finishes on error,
by this reason 'The request could not be completed', which I could not find
much.
but right after the execution of your queries take place, should I run the flow?
best wishes
Raphael

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.