Valued Contributor.. Domoth Valued Contributor..
Valued Contributor..
165 views

OO Studio 10.01 and admin permissions

Jump to solution

Should you be able to run OO Studio 10.01 without local admin permissions on the local computer?

 

If I run studio as a regular user I get this:

 

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Valued Contributor.. Domoth Valued Contributor..
Valued Contributor..

Re: OO Studio 10.01 and admin permissions

Jump to solution

Being a packager in a previous job I had tried this early on in my troubleshooting. This solution alone does not fix the issue because one of the files has different security than all the others.

 

Using sysinternals tools, I found the file "C:\Program Files\Hewlett-Packard\Operations Orchestration\studio\conf\Studio.properties" does not inherit the security permissions like all the other files and folders.

 

To fix the issue I needed to either add back in the inheritance for this file or change it seperatly.

 

After making this change, it now works fine as a regular user.

 

Is this somthing that will be fixed in a future version of studio?

 

Thanks all 🙂

0 Likes
7 Replies
Absent Member.. JasonCantrell Absent Member..
Absent Member..

Re: OO Studio 10.01 and admin permissions

Jump to solution

 

Hello Domoth,

 

I am an OO Support engineer.  Can you please verify if this only happens with regular user permissions? And does it not popup when using any Admin permissions (e.g. domain admin) or if it is only fine if using just local admin?

 

If so, I can check with the team to see if they encountered this and if there is a possible workaround.

 

Kind Regards,

Jason Cantrell

OO Support Representative

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
Valued Contributor.. Domoth Valued Contributor..
Valued Contributor..

Re: OO Studio 10.01 and admin permissions

Jump to solution

Thanks Jason,

 

If I give this same user admin rights and studio opens fine. I take them away and the issue comes back. I have tried it on multiple accounts / pcs to be sure too.

 

Matt

0 Likes
Absent Member.. JasonCantrell Absent Member..
Absent Member..

Re: OO Studio 10.01 and admin permissions

Jump to solution

Ok Matt, thank you very much!

 

I will bring this up on our team call and let you know the workaround/solution.

Also, please tell me what type of business impact is this? Urgent or normal priority?

 

Kind Regards,

Jason

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
Valued Contributor.. Domoth Valued Contributor..
Valued Contributor..

Re: OO Studio 10.01 and admin permissions

Jump to solution

Im about to do an OO 10.01 implimentation for a customer and this was highlighted as a problem (possible show stopper). I logged it with support over two weeks ago and hadnt had much feedback so I thought idd give it a go here.

0 Likes
Absent Member.. daniel_daraban Absent Member..
Absent Member..

Re: OO Studio 10.01 and admin permissions

Jump to solution

Hi Matt,

 

The issue you are encountering is due to the fact that your non-admin user doesn't have the Write permission on the folder where Studio is installed.

 

If you select the Studio folder -> Right Click -> Properties -> Security -> Find the group your non-admin user belongs to -> Provide Write Permission -> Apply-> Apply -> Ok

 

If you log on again with the non-admin user and try to start Studio you will see that Studio will start as expected.

 

If you are still running into any issues please let us know.

 

Have a great day!

 

Best regards,

Daniel

0 Likes
Valued Contributor.. Domoth Valued Contributor..
Valued Contributor..

Re: OO Studio 10.01 and admin permissions

Jump to solution

Being a packager in a previous job I had tried this early on in my troubleshooting. This solution alone does not fix the issue because one of the files has different security than all the others.

 

Using sysinternals tools, I found the file "C:\Program Files\Hewlett-Packard\Operations Orchestration\studio\conf\Studio.properties" does not inherit the security permissions like all the other files and folders.

 

To fix the issue I needed to either add back in the inheritance for this file or change it seperatly.

 

After making this change, it now works fine as a regular user.

 

Is this somthing that will be fixed in a future version of studio?

 

Thanks all 🙂

0 Likes
AngelOO
Visitor.

Re: OO Studio 10.01 and admin permissions

Jump to solution
Hi

Many thanks for your investigation.

HP OO R&D team as recorded this problem under defect: QCCR1D173273. We`ll try to get this fixed asap.

Regards,
Angel
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.