Absent Member.. JasonCantrell Absent Member..
Absent Member..
100 views

[OO Tip] Error: 'Plugin data Jar was not found in studio plugin repository'

Problem:

Using Operations Orchestration (OO) ver 10.01 and following the instructions on  page 28 of the Upgrade Guide under heading 'Upgrading Custom Content'

Document found here: http://support.openview.hp.com/selfsolve/document/KM00515335

Getting an error after running the upgrade content command as per the document and including the custom dll used by the custom operations that was created in version 9.0:

The command is:
upgrade-content.bat --name "XYZ Flows" --publisher XYZ --repo D:\\V9Upgrade\\OOPRODBkp_Local --output D:\\NewRepositories\\OOPRODBkp_Local --inclusions-dir D:\\V9Upgrade\\inclusions --rases-dirs d:\\V9Upgrade\\RAS_list.txt

The lib folder which the documentation references on page 28, "When you upgrade your repository, the upgraded content pack contains custom flows and operations, and a populated Lib folder containing custom IActions JARs/dlls, Maven plugins (wrappers for each custom JAR/dll) and third party dependencies in Maven repository format."

 

When the content is imported, either as a content pack or project, the custom operations all have an error stating 'Plugin data Jar was not found in studio plugin repository'.

 

Solution:

1. Delete the previously deployed XYZ content pack from the Studio
2. Download a 64-bit version of microsoft.grouppolicy.interop.dll from: http://originaldll.com/file/microsoft.grouppolicy.interop.dll/10724.html
3. Replace the Microsoft.GroupPolicy.Management.Interop-1.0.dll file under Lib\\iag\\Microsoft.GroupPolicy.Management.Interop\\1.0 within "XYZ Flows Content V9-CP-1.0.0.jar" by the downloaded 64 bit version (the file name should be modified to be exactly "Microsoft.GroupPolicy.Management.Interop-1.0.dll".
4. Re-import the XYZ content

For Third party issue - sent the jar file with the following folder structure Lib\\com\\microsoft\\Microsoft.Exchange.WebServices\\14.00.0650.007\\

 

Direct link to the document here:

http://support.openview.hp.com/selfsolve/document/KM00699570

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Labels (2)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.