Absent Member.. JasonCantrell Absent Member..
Absent Member..
93 views

[OO Tip] SQL query timeout issue "connection pool size"

Issue:

Using Operations Orchestration, Structured Query Language (SQL) queries can time out. This can happen when using multiple flows and when those flows also do queries to the same database.

In the Remote Action Service (RAS) wrapper.log there will be references to the connection pool size. The size defaults to 100.

 

Solution:

The SQL pooling feature is not used by OO, however because of the Application Programming Interface (API), each connection opened to the same Database, with the same connect string, will increment the pool.

The solution to this issue is to disable the pooling feature.  In the Hostname input add the additional parameter, "Pooling=false".

 

Example:

     <hostname>;Pooling=false

 

For OO version 7.51 patch 02 or 04 must be installed for the above value to work. These patches are not cummulative. Patch 02 will need patch 01 to be installed and patch 04 will need patches 01, 02 and 03 to be installed.

 

Direct link to the document here:

http://support.openview.hp.com/selfsolve/document/KM630427

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Labels (2)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.