Absent Member.. Lim Swee Aun Absent Member..
Absent Member..
665 views

OO WMI query across NAT

Hi,

 

I have OO flow using WMI query.

Works from OO server to test system within same subnet.

When target is across firewall and NAT (network address translation), the flow fails.

- also tested by temporarily opening all firewall ports (ignore firewall for now).

 

MSDN forum seems to say, WMI (based on DCOM) will not work in NATed environment:

http://social.msdn.microsoft.com/Forums/en-US/netfxbcl/thread/99c278fe-df63-408b-b5b1-b95554b6b630/

 

Seems like remote RAS is the answer. But then, is there another way?

- customer has more than 100 branch sites like these.

 

Question 1:

Can anyone confirm what MSDN forum say "DCOM (WMI is based on DCOM) does not work through a NAT" ?

 

Question 2:

Anyone have experience running OO flow using Windows remote commands (eg WMI Query operation) across remote sites with Firewall and NAT?

 

Any pointers will be appreciated.

 

Thanks

swee-aun.lim@hp.com

BSM/BSA presales, Singapore.

 

Labels (1)
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.