Irshad_k Frequent Contributor.
Frequent Contributor.
1524 views

Start Service using HPOO not working on remote server

Hi,

I have created a flow to start services on a server and it is working as expected in studio console. I have deployed the CP on central server and trying to run from there. but it is f ailing for remote server. I tried to start service on local server(HPOO Server) it is working fine fine.

any suggestion why it is not working on remote host from Central console (working fine from Studio) ?

Regards,

Irshad Khan

Labels (1)
0 Likes
9 Replies
EASJosh Respected Contributor.
Respected Contributor.

Re: Start Service using HPOO not working on remote server

Hi Irshad,

What's the error that the operation returns in Central?

Are both the remote server and Central server on the same domain?

Cheers,
Josh


--------------------------------------
If my post helped you, please click the 'Kudos' button.
0 Likes
Irshad_k Frequent Contributor.
Frequent Contributor.

Re: Start Service using HPOO not working on remote server

I have installed both on same server, in execution log it shows following logs but it doesnt seems to be correct to me because everything is working fine on local server and then also I am getting same log messages in execution log.

016-12-08 18:37:19,674 [1_WorkerExecutionThread-5_101000363] (PluginAdapterImpl.java:331) ERROR - System.Management.Automation.RuntimeException: Service Dnscache could not be started.
Possible reasons are-
1. Service does not exist
2. Incorrect username or password
3. Invalid host
4. User may not have privileges to execute this WMI command  ---> System.Management.Automation.RuntimeException: Service Dnscache could not be started.
Possible reasons are-
1. Service does not exist
2. Incorrect username or password
3. Invalid host
4. User may not have privileges to execute this WMI command
   --- End of inner exception stack trace ---
   at System.Management.Automation.Runspaces.PipelineBase.Invoke(IEnumerable input)
   at System.Management.Automation.Runspaces.Pipeline.Invoke()
   at dotNETWebActions_PowerShell.PSScript.Execute(ActionRequest req, ISession s, IActionRegistry reg)Service Dnscache could not be started.

 

attached are the screenshot for the flow and error failure from central console.

0 Likes
EASJosh Respected Contributor.
Respected Contributor.

Re: Start Service using HPOO not working on remote server

Hi Irshad,

Are you able to execute other remote commands to this server?

If not I'd try turning off the firewall (if allowed) on the remote server initially then running again, to see if this is the issue. If this solves it, turn the firewall back on and ensure that the relevant ports are open to enable the remote commands.

Cheers,
Josh


--------------------------------------
If my post helped you, please click the 'Kudos' button.
0 Likes
Irshad_k Frequent Contributor.
Frequent Contributor.

Re: Start Service using HPOO not working on remote server

yes, I tried by running system health checkup templates flow on remote device and it is working fine . issue is with service start/stop operations.

0 Likes
AndreiTruta Outstanding Contributor.
Outstanding Contributor.

Re: Start Service using HPOO not working on remote server

Screenshot_1.png

maybe you could try setting the central service user to an administrator; I am referring to the setting as above.

 

Andrei Vasile Truta
0 Likes
Irshad_k Frequent Contributor.
Frequent Contributor.

Re: Start Service using HPOO not working on remote server

the account I am using to run the services is administrator on remote server.

0 Likes
EASJosh Respected Contributor.
Respected Contributor.

Re: Start Service using HPOO not working on remote server

Can you also check PS remoting is enabled on the remote server?

Run a Powershell command as admin (command below), and try again. If this fails, can you post the inital return that Powershell gives from this command?

COMMAND:

Enable-PSRemoting -Force

--------------------------------------
If my post helped you, please click the 'Kudos' button.
0 Likes
Irshad_k Frequent Contributor.
Frequent Contributor.

Re: Start Service using HPOO not working on remote server

Hi Josh,

I ran this command but still facing the same issue.

Windows PowerShell
Copyright (C) 2009 Microsoft Corporation. All rights reserved.

PS C:\Users\Administrator> Enable-PSRemoting -Force
WinRM already is set up to receive requests on this machine.
WinRM has been updated for remote management.
Created a WinRM listener on HTTP://* to accept WS-Man requests to any IP on this machine.
WinRM firewall exception enabled.

 

I created another flow with "remote command execuiton" operation and given "net start <service name>.  it is working fine.

but issue is still there when I am using "start/stop services" operation in flow.

 

Regards,

Irshad Khan

0 Likes
EASJosh Respected Contributor.
Respected Contributor.

Re: Start Service using HPOO not working on remote server

Hi Irshad,

If you run the following command line, does it show "AllowUnencrypted" as true or false?

winrm get winrm/config

If it shows as false, it might be worth executing this to enable unencrypted traffic:

winrm set winrm/config/client @{AllowUnencrypted="true"}

Failing this, I'd stick with using the Remote Command Execution operation. It works, and it's a really versatile operation.

Hope this has helped!

Cheers,
Josh


--------------------------------------
If my post helped you, please click the 'Kudos' button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.