Chris_Powers Acclaimed Contributor.
Acclaimed Contributor.
245 views

Trouble with NNMi NodeBean WSDL - inputs for getNodes ignored

We have imported in the NNMi NodeBean WSDL into Studio using ws-wizard and specified getNodes. Then we imported this into Studio (10.60) and is available for use.

A flow has been created that mirrors content that works in SOAP-UI (same WSDL used) using getNodes.

What we are seeing are two things:

1) The inputs I specify for getNodes seem to be ignored. I am specifying two things:
     a) I should get custom attribute data in my return data
     b) I should only get one node returned

Instead, I get all nodes and no custom attribute data.

2) So, since my inputs seem to be ignored, I created another flow and did not specify the values from #1 above - I get an error saying:
Empty SOAP body with no child element not supported for RPC

So, I need to specify something, but it will be ignored.

 

Has anyone tried NodeBean and / or have some suggestions as to why we are seeing this behavior?  

Thanks in advance,
Chris

Tags (3)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.