jadda Absent Member.
Absent Member.
319 views

Unable to import HPOO WSDL in servicenow

Jump to solution

Hi All,

 

 I am trying to integrate HPOO and Servicenow. I have successfully imported sericenow WSDL in HPOO. And when trying to import HPOO central WSDL in servicenow I am getting below error "Unable to load WSDL: java.lang.RuntimeException: java.net.ConnectException: Connection refused:java.net.ConnectException: Connection refused"

 

I can access this URL through SOAP  UI and do the required operations.I have installed HPOO and Servicenow Mid server locally.

 

Has anyone faced similar situation ? look at screen shot for details

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Absent Member.. apresence Absent Member..
Absent Member..

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

I'm not sure what's going on with your WSDL.  It looks like you are trying to load it from OO, but SN is trying to access it externally and you're giving it a local/private IP or hostname.  The most recent screenshot you provided has a WSDL that looks like it does not come from OO.  You're on the right track, however.  I think you just need to copy & paste the WSDL from OO into ServiceNow to avoid the WSDL external load issue.

 

Once you've figured all that out, you have to set the mid server at the function level.  You know if you leave that blank it assumes an external service, and your OO instance is internal:

 

 

By the way, this is really a ServiceNow configuration issue and not specifically related to OO.  I suspect you'd have to go through a similar process to integrate with any 3rd party tool.  Have you tried contacting ServiceNow support?

11 Replies
Absent Member.. apresence Absent Member..
Absent Member..

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

At first glance at your screenshot, I see two potential issues:

1. Based on your message, it sounds like your OO server is running on the same host as your MID server.  However, to be safe, I'd suggest using the fully qualified domain name of your OO server instead of "localhost".

2. The HTTPS port for OO is 8443, not 8080.  Try changing that as well.  Another tab appears in your screenshot showing port 8443.

 

Regarding #2, interestingly enough you have your port set to 8080, but the WSDL XML output is looking at localhost:80.  That certainly does not seem right...

 

Let me know how it goes because we were just about to explore doing this integration as well.

 

Thanks!

 

 

- Chris

0 Likes
jadda Absent Member.
Absent Member.

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

Ha Ha. It does not make any differene. both 8080 and 8443 are reserved for HPOO.

 

replaced localhost with IP address, result is same.

0 Likes
Absent Member.. apresence Absent Member..
Absent Member..

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

Are you 100% sure OO is actually listening on port 8080?  The "connection refused" error would seem to indicate that it is not.

 

Try this URL in any browser to be sure:

http://localhost:8080/PAS

 

Regardless of if that works or not, the next thing I would try is change OO to listen on port 80 instead of 8080 since it appears that ServiceNow is somehow trying to use port 80 even though you have told it to use 8080.  Then, update the URL to the WSDL to use port 80 instead of 8080 and see what you get.

 

 

- Chris

0 Likes
jadda Absent Member.
Absent Member.

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

I don't know  on what basis you are telling port 80 for HPOO. Myself configured 8080 and 8443 ports while setting up HPOO. But when I try with 80 it's giving me connection timed out error. May be we need to import  HPOO central cenrtificate here.  

 

 Any Exprt from HP  respond here.

0 Likes
Absent Member.. apresence Absent Member..
Absent Member..

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

I'm getting port 80 from your screenshot. I highlighted the relevant section in following image.  In order to view it full size, save or copy it and open it in Paint or equivalent program (I'm having problems with the attachment feature):

 

In regards to your question about a certificate, since you are not connecting from ServiceNow to OO using an SSL port (port 8443), it should not matter.

0 Likes
jadda Absent Member.
Absent Member.

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

That was old one. attached updated WSDL file. Take a look 

0 Likes
Highlighted
Absent Member.. apresence Absent Member..
Absent Member..

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

I see the WSDL file you posted, but were you able to get that from ServiceNow?  If you got it directly from OO, then it doesn't count ;).

 

Let me try to clarify my point.  In ServiceNow, you configured the WSDL URL to use port 8080 as follows:

 

However, in the WSDL XML window in ServiceNow, it shows an error message for a URL using port 80:

 

It doesn't make sense that port 8080 is getting switched to 80.  That's either a bug with ServiceNow, or maybe it has something to do with the WSDL contents.

 

What I was suggesting is this: To rule out this problem, you can try to re-configure OO to use port 80 instead of 8080, restart OO, update the ServiceNow WSDL URL to use port 80, and try again to see if that works.

 

Of course, this assumes that port 80 isn't already in use...

 

The other thing you could try is changing the WSDL field in Service Now from:

http://localhost:8080/PAS/services/WSCentralService?wsdl

to:

https://localhost:8443/PAS/services/WSCentralService?wsdl

.. however I would expect the same result in either case.

 

 

Thanks!

0 Likes
jadda Absent Member.
Absent Member.

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

Hi , 

 

I have tried with 8443 and got an error "Connection refused" then moved to  8080 port for testing 

 

https://localhost:8443/PAS/services/WSCentralService?wsdl

 

Even though when I try with above URL I got same error. And the WSDL file I have posted contains  port 8443.

0 Likes
jadda Absent Member.
Absent Member.

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

0 Likes
Absent Member.. apresence Absent Member..
Absent Member..

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

I'm not sure what's going on with your WSDL.  It looks like you are trying to load it from OO, but SN is trying to access it externally and you're giving it a local/private IP or hostname.  The most recent screenshot you provided has a WSDL that looks like it does not come from OO.  You're on the right track, however.  I think you just need to copy & paste the WSDL from OO into ServiceNow to avoid the WSDL external load issue.

 

Once you've figured all that out, you have to set the mid server at the function level.  You know if you leave that blank it assumes an external service, and your OO instance is internal:

 

 

By the way, this is really a ServiceNow configuration issue and not specifically related to OO.  I suspect you'd have to go through a similar process to integrate with any 3rd party tool.  Have you tried contacting ServiceNow support?

jadda Absent Member.
Absent Member.

Re: Unable to import HPOO WSDL in servicenow

Jump to solution

Yes. I made a small mistake. If the WSDL is available online then only I should mention at WSDL URL and check the download option. If the WSDL present in customer network, then I should uncheck above option and Paste the WSDL file content in 'WSDL xml' field , which solved my problem. I have done several experiments with above WSDL. 

 

1. Triggered workflow  from HPOO  with  some parameters

 

2. Created new user in HPOO

 

3. created Group 

 

And We have many features to explore.

 

Thanks  apresence for the support.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.