Highlighted
Super Contributor.. Devildiablo Super Contributor..
Super Contributor..
129 views

Using step "Set system property" issue since update

Since our update from 10.80 to 2019.07 the "Set system property" step no longer works.

When we now try to use it we get the following error

java.lang.Exception: java.lang.ClassCastException: java.net.Socket cannot be cast to javax.net.ssl.SSLSocket

Any  ideas?

0 Likes
7 Replies
Micro Focus Expert
Micro Focus Expert

Re: Using step "Set system property" issue since update

Hello Devildiablo,

 

Please open a support ticket to investigate this issue.


Regards! 

Carlos Rojas
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Bridges Respected Contributor.
Respected Contributor.

Re: Using step "Set system property" issue since update

Can you keep us up to date on this issue?  We were thinking about 2019.07, but this issue might stop us.  

0 Likes
Super Contributor.. Devildiablo Super Contributor..
Super Contributor..

Re: Using step "Set system property" issue since update

Hi Bridges,

Will do.... If you dont mind can I ask what version you are currently on?

0 Likes
Bridges Respected Contributor.
Respected Contributor.

Re: Using step "Set system property" issue since update

Sure, we are in the process of moving from 10.60 to 2018.12.
0 Likes
Super Contributor.. Devildiablo Super Contributor..
Super Contributor..

Re: Using step "Set system property" issue since update

We jumped straight from 10.80 to 2019.07 so don't know if it worked in any version after 10.80.

Caused us a few problems with flows that use this step

As you will have seen one of the inputs asks for the version which only goes to 10.50

Surprised they havent kept this step upto date

Will keep updating this discussion

 

 

0 Likes
Bridges Respected Contributor.
Respected Contributor.

Re: Using step "Set system property" issue since update

I believe it is working on 2018.12. We use it for a session id and only update it when it expires. So it is hard to find it in the logs (if it didn't fail, and so far it hasn't).
0 Likes
Bridges Respected Contributor.
Respected Contributor.

Re: Using step "Set system property" issue since update

Could it be the content pack that you are using?  

We used the following:

For 10.60 we have HPE Solutions 1.13.0

For 2018.12 we have Micro Focus Solutions 2.3.1

 

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.