Respected Contributor.. Charlemagne Respected Contributor..
Respected Contributor..
620 views

XML processing (XPath query) and encoding error

Hi everyone,

I am processing some XML fragment I am getting from a RESTful call using the following operation:
/Base [1.9.1]/Library/Utility Operations/XML Processing/XPath Query

This is working just fine in my Studio, once the content pack with my flow is imported on the central this no longer works and I am receiving the following error message:

(exception=Invalid byte 2 of 3-byte UTF-8 sequence.), (returnCode=-1)

Or from the central's log:

INFO   | jvm 1    | 2017/07/19 10:22:34 | [Fatal Error] :1:1: Content is not allowed in prolog.
INFO   | jvm 1    | 2017/07/19 10:22:48 | [Fatal Error] :3:49: Invalid byte 2 of 3-byte UTF-8 sequence.

How can I solve this problem? The original fragment has no XML prolog (<?xml version="1.0" encoding="UTF-8" standalone="yes"?> for example) and I tried to add the XML prolog and it didn't solved the problem.

Any ideas? Someone encountered this problem before?

Regards,

0 Likes
2 Replies
Micro Focus Expert
Micro Focus Expert

Re: XML processing (XPath query) and encoding error

Hello Charlemagne,

 

Thank you for contacting HPE Forum.

 My name is Carlos Rojas, I am from the OO/CSA team.

 

Regarding your question, this behavior is already reported and is in investigation with CPE. A suggest is try with another CP version, could be with the last one (Base 1.10.0) or with another lower and see if the behavior still happening.

 

Best Regards,

 Carlos Rojas

Carlos Rojas
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Contributor.. Calvin_C Contributor..
Contributor..

Re: XML processing (XPath query) and encoding error

I am seeing this issue with 1.12.3 base CP. Has there been any progress? Many have suggested changing the xml output to UTF-8 works but there doesnt appear to be a way to do this in any OO property file.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.