Highlighted
Contributor.
Contributor.
124 views

cental2019.07 and myql 5.2.29 Installation error

Jump to solution

OO_EXECUTION_INTERRUPTS::engine: Change Set META-INF/database/engine.changes.xml::Create OO_EXECUTION_INTERRUPTS::engine failed. Error: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Invalid default value for 'UPDATED_TIME'
INFO | jvm 1 | 2020/04/24 13:05:00 | liquibase.exception.DatabaseException: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Invalid default value for 'UPDATED_TIME'
INFO | jvm 1 | 2020/04/24 13:05:00 | at liquibase.executor.jvm.JdbcExecutor$ExecuteStatementCallback.doInStatement(JdbcExecutor.java:316)
INFO | jvm 1 | 2020/04/24 13:05:00 | at liquibase.executor.jvm.JdbcExecutor.execute(JdbcExecutor.java:55)
INFO | jvm 1 | 2020/04/24 13:05:00 | at liquibase.executor.jvm.JdbcExecutor.execute(JdbcExecutor.java:122)
INFO | jvm 1 | 2020/04/24 13:05:00 | at liquibase.database.AbstractJdbcDatabase.execute(AbstractJdbcDatabase.java:1227)
INFO | jvm 1 | 2020/04/24 13:05:00 | at liquibase.database.AbstractJdbcDatabase.executeStatements(AbstractJdbcDatabase.java:1210)

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi,

This looks to be a missconfiguration of mysql. 

In order to avoid such errors make sure that the following   requirements are met:

- in mysql configuration the property  explicit_defaults_for_timestamps is off or its value is equal to 0 (the way this parameter is set differs a bit  in different versions of mysql).

- in mysql there is a property called sql-mode make sure this property does not include any of the following: NO_ZERO_DATE, NO_ZERO_IN_DATE  or "TRADITIONAL"

 

For other settings needed in mysql server configuration in order to run you can look at: https://docs.microfocus.com/itom/Operations_Orchestration:2020.02/DeployMySQLOO

 

Also make sure during instalation to use the 5.1.35 version of the jdbc driver. 

Hope this helps,

Vlad

View solution in original post

4 Replies
Highlighted
Contributor.
Contributor.

mysql5.7.29 for redhat7.6 64bit x86

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor
Is it possible to provide full install llogs?
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi,

This looks to be a missconfiguration of mysql. 

In order to avoid such errors make sure that the following   requirements are met:

- in mysql configuration the property  explicit_defaults_for_timestamps is off or its value is equal to 0 (the way this parameter is set differs a bit  in different versions of mysql).

- in mysql there is a property called sql-mode make sure this property does not include any of the following: NO_ZERO_DATE, NO_ZERO_IN_DATE  or "TRADITIONAL"

 

For other settings needed in mysql server configuration in order to run you can look at: https://docs.microfocus.com/itom/Operations_Orchestration:2020.02/DeployMySQLOO

 

Also make sure during instalation to use the 5.1.35 version of the jdbc driver. 

Hope this helps,

Vlad

View solution in original post

Highlighted
Contributor.
Contributor.
VladM,resolved,thank you. in mysql ,I remove "NO_ZERO_DATE, NO_ZERO_IN_DATE or "TRADITIONAL"
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.