Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..
111 views

flow finished but appears as running keeps reexecuting the steps

Jump to solution

Hi,

 

We have a clustered installation of OO with two central servers, 2 RAS and a HAProxy load balancer.

 

We recently did some changes with the linux team in the HAProxy configuration. After this, the steps in the flow execute 2 or more times (Even when just having 1 central up and running.) The flow appears as running even when the drilldown shows that it already finished.

Have anyone has experienced something similar?

in the logs we see the following.

2020-07-20 13:00:15,631 [scoreWorkerScheduler-4] (OutboundBufferImpl.java:172) ERROR - Failed to drain buffer, invoking worker internal recovery...
java.lang.RuntimeException: runningExecutionPlan is null

Best regards.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello carlosgarza94,

 

Please open a support incident in order to investigate this behavior properly.

 

Regards!

Carlos Rojas
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.

View solution in original post

2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello carlosgarza94,

 

Please open a support incident in order to investigate this behavior properly.

 

Regards!

Carlos Rojas
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.

View solution in original post

Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Hi @Carlos_Rojas_OO we followed your advice and opened a case. The issue was that the workers were taking and executing stale records from the OO database.

 

Thank you for your advice.

Best regards,

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.