SergioB Super Contributor.
Super Contributor.
400 views

how to filter out special character on an operation result.

Hello

An output from an SSH operation is returning a special characters, in porticular, it is returning 

'BACKSPACE' (U+0008) 

 

I tried to use the result filter option with the "replace" to replace the bad character (copied from the flow variable). In the screen it looks like a square.

But when I try to upload to central it complains that this character is not valid

"Character reference "&#x08" is an invalid XML character..

Have any of you experienced this before? How do I filter out this bad character from my Result?

I tried using \b but is not recognized. \x08 \x008 \ , etc... 

 

Any help is appreciated

0 Likes
1 Reply
Knowledge Partner
Knowledge Partner

Re: how to filter out special character on an operation result.

Hi there

I had a similar type of problem whereby OO had problems replacing or removing a certain string of characters.

There was 2 things that worked

1. Remove the string in 2 parts, first strip a couple of the characters out and then run another replace to remove the rest

2. Add a couple of characters and then strip all of the original+additional characters out

Or use a combination of doing 2 first and then 1

 

Not sure if it will solve your problem, let me know

Ciao

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.