Devastazione Absent Member.
Absent Member.
1082 views

newScale To HP OO integration - call webservice - authentication issue

Hi, 

 

i try to integrate "Cisco newScale" portal with HP OO by calling HP OO webservice (using runFlow method), but i get this error:

 

<?xml version="1.0" encoding="UTF-8"?>

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><soapenv:Fault><faultcode xmlns:ns1="http://xml.apache.org/axis/">ns1:Authentication</faultcode><faultstring>Failure: User was not authenticated. Please see log file for details.

Must provide user name/password, lwsso token, or SSO kerberos token for authentication.</faultstring><detail><ns2:hostname xmlns:ns2="http://xml.apache.org/axis/">SVGEMOP083</ns2:hostname></detail></soapenv:Fault></soapenv:Body></soapenv:Envelope>

 

I call runFlow method by this request body: 

 

<soapenv:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsc="http://wscentralservice.services.dharma.iconclude.com" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">
   <soapenv:Header/>
   <soapenv:Body>
      <wsc:runFlow soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
         <params xsi:type="soap:WSRunParameters" xmlns:soap="http://iconclude.com/webservices/rss/v2.0/soap">
            <async xsi:type="xsd:boolean">True</async>
            <flowInputs xsi:type="wsc:ArrayOf_tns1_WSFlowInput" soapenc:arrayType="soap:WSFlowInput[]" xmlns:wsc="https://192.168.142.42/PAS/services/WSCentralService"/>
            <startPaused xsi:type="xsd:boolean">False</startPaused>
            <trackStatus xsi:type="xsd:boolean">False</trackStatus>
            <uuid xsi:type="xsd:string">123456789</uuid>
         </params>
      </wsc:runFlow>
   </soapenv:Body>
</soapenv:Envelope>

 

Can somebody help me?

 

Regards,

Biagio

Labels (3)
0 Likes
2 Replies
Honored Contributor.. RiverRat_1 Honored Contributor..
Honored Contributor..

Re: newScale To HP OO integration - call webservice - authentication issue

Do you have the OO SDK downloaded ?

 

Then look at the OO Software Developers Guide.  Look on page 46 and in the "samples\client\java\src" subfolder of the SDK bits. That might help.

 

 

0 Likes
SLippi Absent Member.
Absent Member.

Re: newScale To HP OO integration - call webservice - authentication issue

Was this ever figured out?  I have the same problem using .net and can't seem to find out what I'm missing. Thanks.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.