rojamasa Absent Member.
Absent Member.
191 views

"Invalid directory" error when trying to save email attachment from MS Exchange server.

Hi,

 

When I try and use the operation "read attachment to a file" to get the Exchange email´s attachment I get a "invalid directory" error.

 

The URL that I use is the URL that read next email returns.

 

The only doubt that I have is the parameter "mailbox". The description says that one must use 'the mailbox specified in the URL instead of the username'. What does this mean?

 

e.g. URL = "https://exchangeServerIP/mailboxUserName/mailbox/emailTitle/attachmentName"

 

So in this example, what is the correct value of the parameter 'mailbox'?

 

Thanx

 

Jay

Labels (1)
0 Likes
1 Reply
negruseri Absent Member.
Absent Member.

Re: "Invalid directory" error when trying to save email attachment from MS Exchange server

Hello Jay.

Read Attachment to File operation was deprecated in OO 9.00.05. The content release was in 2011.04.22.
The new Read Attachment operation does not use the URL anymore but the attachmentId and filePath inputs to get/store the attachment of your email.

Hope this helps,
Daniel

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.