countryStyle Absent Member.
Absent Member.
1402 views

sendmail .net and java versions

After wasting 3 hours trying to figure out the .net and java versions of the sendmail I give up.

 

OO is at 9.02 on a windows box

 

Java. Can send a mail to one receipient but not to multiple receipients:

-have used "," (comma) to seperate the names and specified it as a delimeter.

-have also used the default ";"

-continually receive the error that the email address has an illegal whitespace comma or semi-colon.

-I have also tried inputing the email addresses manually.

-I have tried including and not including whitespace around the delimiter.

 

Is there a list appender or something that is supposed to be used with thiw widget?

 

{returnCode=-1;returnResult=Illegal semicolon, not in group;Result=Illegal semicolon, not in group;sessionId=458a1422-fb4b-4fa4-916a-c4318134f40f;exception=javax.mail.internet.AddressException: Illegal semicolon, not in group in string ``bob@hotmail.com ; bob@ontario.ca'' at position 16
 at javax.mail.internet.InternetAddress.parse(InternetAddress.java:780)
 at javax.mail.internet.InternetAddress.parse(InternetAddress.java:555)
 at javax.mail.internet.InternetAddress.<init>(InternetAddress.java:91)
 at com.iconclude.content.actions.mail.SendMail.execute(SendMail.java:229)
 at com.iconclude.webservices.ras.classLoadedIaction.execute(JavaExtensionService.java:575)
 at com.iconclude.webservices.ras.JavaExtensionService.executeFromThisDelegator(JavaExtensionService.java:257)
 at com.iconclude.webservices.ras.ExtensionServiceDelegator.execute(ExtensionServiceDelegator.java:58)
 at com.iconclude.webservices.ras.RCAgentServiceSoapBindingImpl.execute(RCAgentServiceSoapBindingImpl.java:48)
 at com.iconclude.webservices.ras.RCAgentServiceSoapBindingSkeleton.execute(RCAgentServiceSoapBindingSkeleton.java:238)
 at sun.reflect.GeneratedMethodAccessor85.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
 at java.lang.reflect.Method.invoke(Unknown Source)
 at org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:397)
 at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:186)
 at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:323)
 at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
 at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
 at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
 at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:454)
 at org.apache.axis.server.AxisServer.invoke(AxisServer.java:281)
 at org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:699)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
 at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
 at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:502)
 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1124)
 at org.acegisecurity.securechannel.ChannelProcessingFilter.doFilter(ChannelProcessingFilter.java:138)
 at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)
 at com.iconclude.dharma.commons.util.http.DharmaFilterToBeanProxy.doFilter(DharmaFilterToBeanProxy.java:49)
 at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
 at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:361)
 at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
 at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
 at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
 at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:417)
 at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
 at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
 at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
 at org.mortbay.jetty.Server.handle(Server.java:324)
 at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:534)
 at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:879)
 at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:741)
 at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:207)
 at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:403)
 at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
 at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:522)
;}

 

 

 

.NET continually receive the error

{returnCode=1;returnResult=The specified string is not in the form required for an e-mail address.;Result=The specified string is not in the form required for an e-mail address.;sessionId=2dc58f8d-bd00-4fc1-a12d-87546a9e6591;exception=System.FormatException: The specified string is not in the form required for an e-mail address.
   at System.Net.Mime.MailBnfHelper.ReadMailAddress(String data, Int32& offset, String& displayName)
   at System.Net.Mail.MailAddress.ParseValue(String address)
   at System.Net.Mail.MailAddress..ctor(String address, String displayName, Encoding displayNameEncoding)
   at dotNETWebActions_SendMail.SendSMTPMail..ctor(ActionRequest req)
   at dotNETWebActions_SendMail.SendMail.Execute(ActionRequest req, ISession s, IActionRegistry reg);}

 

again I have done the manual input thing  and use d a constant and checked the debugger for the string values.  last time I checked bob@bob.com was a valid email address string so this one is really puzzling me.  What is considered a valid email string?  I dont know what version of patch level the .net framewor is at.

 

 

????I would like to say WTF????

 

any help out there?

Labels (1)
Tags (1)
0 Likes
2 Replies
AlexC Absent Member.
Absent Member.

Re: sendmail .net and java versions

Hi,

 

The issue you describe  with the java operation was fixed since OO content patch 9.00.03. Please use the latest content available on HP Live Network: 9.00.06.

 

The java operation can send an email to multiple users entered in the input field "to". The addresses in this list are separated by the "delimiter" input, which by default is semicolon (;).

Example:

to: Tom@mail.com;**bleep**@mail.com ; Harry@mail.com

delimiter: <empty>

 

The above example will send an email to Tom and will CC all the others in the list.

The problem with the .Net operation is known and will be fixed in a future release.

 

Regards,

Alex

0 Likes
countryStyle Absent Member.
Absent Member.

Re: sendmail .net and java versions

Hi Alex,

 

Thanks for replying.  I have since been in contact with HP Support.  I am on 9.02.00

The item was fixed and then was broken again in subsequent releases.

 

HP is working on the issue now.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.