Absent Member.. DBR Absent Member..
Absent Member..
131 views

xPath/xPathQuery question

Jump to solution

I am making a call to a Service Manager WSDL.  I have attached what I am sending and what I am getting back.  The xPathQuery I am doing in OO is below.  I don't know where the attachments went.

In the request there are 10 fields being requested but only two are being returned in the xml since they are empty fields.

 

//SizeMB/text() | //DiskType/text() | //Volume/text() | //Group/text() | //Owner/text() | //PartitionDirectoryMountPoint/text() | //Permissions/text() | //SharedHost/text() | //SharedHostName/text() | //Notes/text()

 

The about works great IF the SM WSDL returns all of the fields.  If it doesn't it puts the first value in SizeMB even though that is not what it is.

 

Is there anyway around this?

 

Thanks,

Don

 

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Absent Member.. DBR Absent Member..
Absent Member..

Re: xPath/xPathQuery question

Jump to solution

I got this working by changing the xpath query to the below.

 

concat( //SizeMB[node()] ,',', //DiskType[node()] , ',' , //Volume[node()] , ',' , //Group[node()]  , ',' , //Owner[node()]  , ',' , //PartitiondirectoryMountPoint[node()]  , ',' , //Permissions[node()]  , ',' , //SharedHost[node()]  , ',' , //SharedHostName[node()]  , ',' , //Notes[node()] )

 

Don

 

0 Likes
2 Replies
Absent Member.. JasonCantrell Absent Member..
Absent Member..

Re: xPath/xPathQuery question

Jump to solution

Hello,

 

I am an engineer with the OO support group.  Could you please post what content pack you are at -  %iconclude_home%\updates\content list the subdirs to find the content pack – can you also provide the sample input string (working and not working ).  We need to confirm the filter below is the correct one you are using.

 

If you are not at a recent content pack you could try the filter on your version and then on the lastest version and see if they are different.  We can also look at how multiple queries can be added – need to find which is more correct…

 

Regards,

Jason

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
Absent Member.. DBR Absent Member..
Absent Member..

Re: xPath/xPathQuery question

Jump to solution

I got this working by changing the xpath query to the below.

 

concat( //SizeMB[node()] ,',', //DiskType[node()] , ',' , //Volume[node()] , ',' , //Group[node()]  , ',' , //Owner[node()]  , ',' , //PartitiondirectoryMountPoint[node()]  , ',' , //Permissions[node()]  , ',' , //SharedHost[node()]  , ',' , //SharedHostName[node()]  , ',' , //Notes[node()] )

 

Don

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.