achinayoung_wau Respected Contributor.
Respected Contributor.
847 views

Access to reporting module

We have PAM 3.2.0.6 configured and would like to give some uses restricted access to view the Reporting logs. I created a "Reporting" user group with access to the following modules/roles:
audit command
audit console
audit login
audit read

The restricted user can log in and sees only the Reporting module. When they click on the Reporting module, the default report looks normal. Clicking on one of the entries to view the video recording, then the "Output" button and then the "Playback" button brings up a web browser prompt for the username/password. Note that while this prompt is displayed, the video recording is playing in the background!

If I add the following module/role to the above, the web browser prompt for username/password does not appear:
audit admin

Are things working as intended?
0 Likes
2 Replies
AutomaticReply Absent Member.
Absent Member.

Re: Access to reporting module

achinayoung,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Access to reporting module

I am not able to duplicate this in PAM 3.2.0.6 or PAM 3.5 and haven't heard of an issue similar. What I expect is going on has something to do with browser cache perhaps. No videos are fetched until the credential is verified. Once verified, they aren't prompted every time they access video playback for a report. So once their session has verified the credential to access video playback, they aren't prompted again, unless expiration occurs.

So perhaps this test you are doing with the audit roles doesn't appear quite right because the audit user is logged in. Try logging out, Ctrl + F5 refresh, and re-login and then perhaps even an incognito window or another browser just to verify.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.