Commodore
Commodore
588 views

Agent installation on SLES 15

I am trying to install netiq-npam-3.6.0-0.x86_64 on a SLES 15 server:

# rpm -Uvh /tmp/netiq-npam-agent-3.6.0-linux-2.6-x86_64.rpm
error: Failed dependencies:
lsb >= 3.0 is needed by netiq-npam-3.6.0-0.x86_64
libncurses.so.5()(64bit) is needed by netiq-npam-3.6.0-0.x86_64

There is no lsb or ncurses v5 package in SLES 15.

# zypper search lsb
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
--+-------------+-----------------------------------+--------
| lsb-release | Linux Standard Base Release Tools | package

# zypper search ncurses
Loading repository data...
Reading installed packages...

S | Name | Summary | Type
---+--------------------------+----------------------------------------+--------
i+ | libncurses6 | Terminal control library | package
| libncurses6-32bit | Terminal control library | package
| libyui-ncurses-devel | Libyui-ncurses header files | package
| libyui-ncurses-doc | Libyui-ncurses documentation | package
| libyui-ncurses-pkg-devel | Libyui-ncurses-pkg header files | package
| libyui-ncurses-pkg-doc | Libyui-ncurses-pkg documentation | package
i | libyui-ncurses-pkg9 | Libyui - yast2 package selector widg-> | package
| libyui-ncurses-tools | Libyui-ncurses tools | package
i | libyui-ncurses9 | Libyui - Character Based User Interf-> | package
| ncurses-devel | Development files for the ncurses6 t-> | package
i+ | ncurses-utils | Tools using the new curses libraries | package

0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

0 Likes
Commodore
Commodore

Can we pull the agent from the PAM 3.7 distribution and run it against a 3.6 setup?

0 Likes
Micro Focus Expert
Micro Focus Expert

No, we don't recommend differing versions within the same framework.

I recommend installing the lsb and ncurses packages from OS distribution and then try the install again. For example:

opensuse-15-leap:~ # zypper addrepo https://download.opensuse.org/distribution/leap/15.0/repo/oss/ opensuse-15-leap
opensuse-15-leap:~ # zypper patch
opensuse-15-leap:~ # rpm -ivh netiq-npam-manager-3.5.0-linux-2.6-x86_64.rpm
error: Failed dependencies:
lsb >= 3.0 is needed by netiq-npam-3.5.0-0.x86_64
libncurses.so.5()(64bit) is needed by netiq-npam-3.5.0-0.x86_64
opensuse-15-leap:~ # zypper in lsb
opensuse-15-leap:~ # zypper in libncurses5
opensuse-15-leap:~ # rpm -ivh netiq-npam-manager-3.5.0-linux-2.6-x86_64.rpm
Preparing... ################################# [100%]
Updating / installing...
1:netiq-npam-3.5.0-0 ################################# [100%]
npum 0:off 1:off 2:on 3:on 4:on 5:on 6:off
Setting up init scripts...
npum.service is not a native service, redirecting to systemd-sysv-install.
Executing: /usr/lib/systemd/systemd-sysv-install enable npum

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Such packages are often available from the SLES legacy module:

zypper search-packages libncurses5
Following packages were found in following modules:

Package                      Module or Repository                                                        SUSEConnect Activation Command
---------------------------  --------------------------------------------------------------------------  ---------------------------------------------------
libncurses5                  Legacy Module (sle-module-legacy/15.2/x86_64)                               SUSEConnect --product sle-module-legacy/15.2/x86_64
libncurses5-32bit            Legacy Module (sle-module-legacy/15.2/x86_64)                               SUSEConnect --product sle-module-legacy/15.2/x86_64
libncurses5-32bit-debuginfo  Legacy Module (sle-module-legacy/15.2/x86_64)                               SUSEConnect --product sle-module-legacy/15.2/x86_64
libncurses5-debuginfo        Legacy Module (sle-module-legacy/15.2/x86_64)                               SUSEConnect --product sle-module-legacy/15.2/x86_64
libncurses5-32bit            Available in repo Legacy_Module_15_SP2_x86_64:SLE-Module-Legacy15-SP2-Pool
libncurses5                  Available in repo Legacy_Module_15_SP2_x86_64:SLE-Module-Legacy15-SP2-Pool

To activate the respective module or product, use SUSEConnect --product.
Use SUSEConnect --help for more details.
--
Norbert
0 Likes
Micro Focus Expert
Micro Focus Expert

Yes perfect, thanks Norbert. I recommend sourcing from the most relevant OS distribution/repo and installing to fulfill the library requirements of the install.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.