achinayoung_wau Respected Contributor.
Respected Contributor.
788 views

Failure to run command with usrun

I am trying to set up a simple rule to allow "usrun pcksh". I followed the instructions in the Admin manual on pages 247-249. However, I am getting a strange error:
$ usrun pcksh
This session is being recorded.

Failed to find remote user 'xyz\SubmitUser'


In our "xyz" vault, we do have a "SubmitUser" credential.

Looks like this error is output even if there is no rule to audit UNIX commands. The same error is displayed if I run "usrun blah":
$ usrun blah
This session is being recorded.

Failed to find remote user 'xyz\SubmitUser'


The rule:


And the "pcksh Command" from the rule:


Any ideas?
0 Likes
1 Reply
achinayoung_wau Respected Contributor.
Respected Contributor.

Re: Failure to run command with usrun

Found the problem. I had a rule condition on the parent rule, "UNIX (commands)". Removed that and "usrun pcksh" worked. Could definitely use a better error message.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.