Micro Focus Contributor
Micro Focus Contributor
277 views

redhat enterprise install PAM 3.7's issue

Hi Colleague,

I was installed PAM client 3.7 in redhat enterprise 7.9 but i got following error message 

pm -i netiq-npam-agent-3.7.0-linux-3.0-intel.rpm
error: Failed dependencies:
libcrypt.so.1 is needed by netiq-npam-3.7.0-0.i386
libcrypt.so.1(GLIBC_2.0) is needed by netiq-npam-3.7.0-0.i386
libc.so.6 is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.0) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.1) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.10) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.1.2) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.1.3) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.2) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.2.4) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.3) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.3.2) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.3.3) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.3.4) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.4) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.7) is needed by netiq-npam-3.7.0-0.i386
libc.so.6(GLIBC_2.9) is needed by netiq-npam-3.7.0-0.i386
libdl.so.2 is needed by netiq-npam-3.7.0-0.i386
libdl.so.2(GLIBC_2.0) is needed by netiq-npam-3.7.0-0.i386
libdl.so.2(GLIBC_2.1) is needed by netiq-npam-3.7.0-0.i386
libm.so.6 is needed by netiq-npam-3.7.0-0.i386
libm.so.6(GLIBC_2.0) is needed by netiq-npam-3.7.0-0.i386
libncurses.so.5 is needed by netiq-npam-3.7.0-0.i386
libnsl.so.1 is needed by netiq-npam-3.7.0-0.i386
libpam.so.0 is needed by netiq-npam-3.7.0-0.i386
libpam.so.0(LIBPAM_1.0) is needed by netiq-npam-3.7.0-0.i386
libpthread.so.0 is needed by netiq-npam-3.7.0-0.i386
libpthread.so.0(GLIBC_2.0) is needed by netiq-npam-3.7.0-0.i386
libpthread.so.0(GLIBC_2.1) is needed by netiq-npam-3.7.0-0.i386
libpthread.so.0(GLIBC_2.1.1) is needed by netiq-npam-3.7.0-0.i386
libpthread.so.0(GLIBC_2.2) is needed by netiq-npam-3.7.0-0.i386
libpthread.so.0(GLIBC_2.3.2) is needed by netiq-npam-3.7.0-0.i386
libpthread.so.0(GLIBC_2.4) is needed by netiq-npam-3.7.0-0.i386
libresolv.so.2 is needed by netiq-npam-3.7.0-0.i386
libresolv.so.2(GLIBC_2.0) is needed by netiq-npam-3.7.0-0.i386
libresolv.so.2(GLIBC_2.2) is needed by netiq-npam-3.7.0-0.i386
librt.so.1 is needed by netiq-npam-3.7.0-0.i386
librt.so.1(GLIBC_2.2) is needed by netiq-npam-3.7.0-0.i386
libutil.so.1 is needed by netiq-npam-3.7.0-0.i386
libutil.so.1(GLIBC_2.0) is needed by netiq-npam-3.7.0-0.i386

 

 

so what package require to install before install PAM 3.7? Thanks

 

 

BR

Bill

0 Likes
1 Reply
Micro Focus Expert
Micro Focus Expert

Try installing with the "x86_64" instead of the "intel" rpm, for example:
rpm -i netiq-npam-agent-3.7.0-linux-3.0-x86_64.rpm
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.