L Pennington Super Contributor.
Super Contributor.
201 views

PC 12.20 MI Listener woes

Jump to solution

New cloud installation of PC 12.20 with a separate MI Listener running on Win 2008 R2 SP1. 

I cannot add a remote host to connect via the MI Listener in LAB Management. Firewalls etc are all open, and MI Listener is listening on both 443 and 50500.

 

Now if I try and connect from a standalone LR 12.02 Controller to the same remote LG via the same MI Listener I get a good connection, so I can assume the MI Listener is working properly. 

 

Error when adding new host from Lab Mgmt says "The host "xxxx" is not connected to MI Listener "10.0.0.10". Please check agent configuration on host machine. The Local machine key on LG host is same as the name entered in Lab Mgmt.

 

What is so special about PC communications that it won't add the host when it works with LR 12.02 Controller?? Getting very frustrated as there appears to be very little logging on this, ALM logs just clarify what I already know.

 

Luke.

0 Likes
1 Solution

Accepted Solutions
Highlighted
L Pennington Super Contributor.
Super Contributor.

Re: PC 12.20 MI Listener woes

Jump to solution

I have found that the hostname cannot have a hyphen in it. It maybe you can only have alphanumeric characters?? 

Changing from vm-24567 to vm24567 worked for me.

 

0 Likes
3 Replies
Absent Member.. LG3 Absent Member..
Absent Member..

Re: PC 12.20 MI Listener woes

Jump to solution

"The Local machine key on LG host is same as the name entered in Lab Mgmt."

 

The local machine key should be somename_location.

 

Please see if it helps.

 

Lionel

 

 

0 Likes
Highlighted
L Pennington Super Contributor.
Super Contributor.

Re: PC 12.20 MI Listener woes

Jump to solution

I have found that the hostname cannot have a hyphen in it. It maybe you can only have alphanumeric characters?? 

Changing from vm-24567 to vm24567 worked for me.

 

0 Likes
Absent Member.. LG3 Absent Member..
Absent Member..

Re: PC 12.20 MI Listener woes

Jump to solution

Great to hear it's working for you.

Here I have no issue with hyphen and underscore, both in machine key or location name.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.