Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Dennis Honored Contributor.
Honored Contributor.
480 views

PC12.50 scheduled test - Run test failed. 'Object reference not set to an instance of an object.'

Jump to solution

Hi all,

(This als posted in: Performance Center Support and News Forum, thread is here)

I am pretty new to PC. The past few working days I have been working on the installation of HP ALM Performance Center Edition V12.50.

To get the product to now, I created a simple Loadrunner webscript in which I perform some calls to a webservice.
I created a test in PC, with this script, and this test runs fine as long as I trigger it manually through Test Management -> Test Lab, select my test and press "Run Test".
This creates a AdhocRun in PC, see in attached screenshot "AdhocRun_2015_12_07 10:22:32" with a state of Finished

But when I try to schedule the test, to run it automatically, it always fails.
See the attached screenshot, "AutoStartRun_2015_12_07 10:45:55", state Run Failure.

When looking at the Event Log of that test, it states: "Run test failed. Reason: 'Object reference not set to an instance of an object.'"

I have been looking at:
- PC System Health @ HP ALM, everything is OK;
- looking in logfiles on the ALM server: <installdir>\ProgramData\HP\ALM\log, I can not find entries about this issue;
- looking in the database, I do not know where to look, so much tables...

Bottomline: Why doesn't the test run scheduled through a timeslot?

Anny help appreciated and thanks in advance.
Dennis

NB: If this solves your problem / helps you on the way, consider acknowledging with Kudos. To kudo a post, select the thumbs up icon in the gray square by the post in the thread.
0 Likes
1 Solution

Accepted Solutions
Highlighted
Dennis Honored Contributor.
Honored Contributor.

Re: PC12.50 scheduled test - Run test failed. 'Object reference not set to an instance of an object.

Jump to solution

I solved it myself.

The reason why this behaviour occurs is because I did not check-in the test under Test Management -> Testplan -> Edit Test.

If the test is not checked-in you can run it manually.
Checking the test in helped me to run the test scheduled in a timeslot.

 

NB: If this solves your problem / helps you on the way, consider acknowledging with Kudos. To kudo a post, select the thumbs up icon in the gray square by the post in the thread.
4 Replies
Daniela_G Acclaimed Contributor.
Acclaimed Contributor.

Re: PC12.50 scheduled test - Run test failed. 'Object reference not set to an instance of an object.

Jump to solution

Hello asr_Dennis

 

In order to have a better look on this, I appreciate if you can share the PC Server logs. This are on the <installation folder>\HP\Performance Center Server\orchidtmp.

 

If you can attach the entire orchidtmp folder would be great, if not, please try with the LTlogger.

 

 

Regards,

Daniela Gómez Alvarado
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Dennis Honored Contributor.
Honored Contributor.

Re: PC12.50 scheduled test - Run test failed. 'Object reference not set to an instance of an object.

Jump to solution

Hi Daniela Gómez Alvarado,

Is it possible to sent the requested folder through a more secure channel then through this open forum?
I have been looking at private messages (PM) on the forum, but I can not attach files at a pm.

I zipped the folder and it's size is about 1,6MB.

Thank you,

Dennis

NB: If this solves your problem / helps you on the way, consider acknowledging with Kudos. To kudo a post, select the thumbs up icon in the gray square by the post in the thread.
0 Likes
Dennis Honored Contributor.
Honored Contributor.

Re: PC12.50 scheduled test - Run test failed. 'Object reference not set to an instance of an object.

Jump to solution

I found this in a logfile: HP.PC.Rest.Exceptions.RestCommonException: AppContext cannot be empty. Please register to the event 'RestProxy.OnAppContextRequired' and provide app context. This can be either by authenticating to ALM server using AuthenticationProxy or by costum mean.

NB: If this solves your problem / helps you on the way, consider acknowledging with Kudos. To kudo a post, select the thumbs up icon in the gray square by the post in the thread.
0 Likes
Highlighted
Dennis Honored Contributor.
Honored Contributor.

Re: PC12.50 scheduled test - Run test failed. 'Object reference not set to an instance of an object.

Jump to solution

I solved it myself.

The reason why this behaviour occurs is because I did not check-in the test under Test Management -> Testplan -> Edit Test.

If the test is not checked-in you can run it manually.
Checking the test in helped me to run the test scheduled in a timeslot.

 

NB: If this solves your problem / helps you on the way, consider acknowledging with Kudos. To kudo a post, select the thumbs up icon in the gray square by the post in the thread.
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.