WissenCarquest Absent Member.
Absent Member.
892 views

Add custom proposal,Risk and issue request types

Jump to solution

 

Hello Friends,

 

Recently we have upgrade PPM application from 7.5 to 8.0. After upgrade we have changed menu.xml with custom proposal ,risk and issue request types. after that I have copied to /conf/memus/ and restart the server. I have opend the main page I got extra extra menus under open menu. after that I have copied original backup menu.xml (I mean before change menu.xml) to menu.xml.

and restart the server, even I got same extra menus under open menu. Could you please suggest what files need to be chage.

 

Please find the attached screen shot.

 

Thanks,

Prasad A

0 Likes
1 Solution

Accepted Solutions
WissenCarquest Absent Member.
Absent Member.

Re: Add custom proposal,Risk and issue request types

Jump to solution

Thanks you all. We finally  fixed the probelm.

I removed backup of xml file from /conf/menus and restart the server .

(NOTE: as i have not deleted old xml file,so it is taking both old and new xml files. we have deleted old xml file from menus folder now it is working fine.  )

 

 

Thanks,

Prasad a

0 Likes
8 Replies
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Add custom proposal,Risk and issue request types

Jump to solution

I wish I had a solution, but I don't. We had the same thing happen in our development environment after upgrading to 9.12 and have not been able to find a fix. We worked with HP on this for at least 6 months and they could not identify the problem or a solution either. I hope someone here has some helpful insight on this.

0 Likes
Absent Member.. Niraj Prabhu Absent Member..
Absent Member..

Re: Add custom proposal,Risk and issue request types

Jump to solution
Prasad,

have you tried to delete the tmp and work folder before the restart? and also if you have multiple nodes for your application? If yes then did restart all of them?
Niraj P.
Highlighted
WissenCarquest Absent Member.
Absent Member.

Re: Add custom proposal,Risk and issue request types

Jump to solution

Hello Niraj,

 

I have delete temp and work, My application running on single server. even I ran kJSPcompiler.sh, kUpdateHtml.sh and kRunchahemanger.sh also. here no luck. Could you please some one help me on this.

 

Thanks,

Prasad A

Absent Member.. Niraj Prabhu Absent Member..
Absent Member..

Re: Add custom proposal,Risk and issue request types

Jump to solution
Prasad,

Did you try to clear cache on your local browser?
Niraj P.
WissenCarquest Absent Member.
Absent Member.

Re: Add custom proposal,Risk and issue request types

Jump to solution

Hello Niraj,

 

No luck.

 

 

Thanks,

Prasad A

0 Likes
Absent Member.. penoles Absent Member..
Absent Member..

Re: Add custom proposal,Risk and issue request types

Jump to solution

when parsing menu items, PPM picks all files ended in .xml. So do not put backups of Menu.xml in the same folder. 

Absent Member.. philipwood Absent Member..
Absent Member..

Re: Add custom proposal,Risk and issue request types

Jump to solution

 

 

 

Hi,

 

Don't know if this helps.

I experienced a similar problem on a DEV environment some time last year.

 

My final solution was a bit brute force:

In the end I regenerated the filesystem for the instance.

i.e. I took a working normal instance of the same version and SP - copied its entire filesystem and then reconfigured it for the new filesystem location and then configured it to use the database of the instance that was having the problem.

 

That was a dev so I had no need to worry about preserving data -

 

Keep in mind that you need to make sure everything stored in the filesystem is preserved:

  • license
  • documents in attachments folder or dms configuration
  • logs
  • reports
  • custom config (the ones that are not causing problems 🙂 )
  • etc.

Regards

 

Philip Wood

0 Likes
WissenCarquest Absent Member.
Absent Member.

Re: Add custom proposal,Risk and issue request types

Jump to solution

Thanks you all. We finally  fixed the probelm.

I removed backup of xml file from /conf/menus and restart the server .

(NOTE: as i have not deleted old xml file,so it is taking both old and new xml files. we have deleted old xml file from menus folder now it is working fine.  )

 

 

Thanks,

Prasad a

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.