DanielJiang Respected Contributor.
Respected Contributor.
396 views

Error when running the kLicenseInstall.sh after PPM 9.30 Upgrade

Just after successfully completed the PPM 9.30 Upgrade from PPM 9.22. We failed at following step of installing the new PPM 9.30 license. I was able to install two license .dat files and then failed on rest of them, and I couldn’t re-install those two previous dat file either. The error I received is:

$ sh kLicenseInstall.sh conf/DEVlicense/MDS6605_T5585AAE_19-04-201606-08-54-863.DAT

JAVA_HOME = /cygdrive/d/Server_Apps/jdk1.7.0_55

java version "1.7.0_55"

Java(TM) SE Runtime Environment (build 1.7.0_55-b13)

Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)

Installing Fail:ERROR IN PRODUCT CONFIGURATION FILE UNMARSHALLING;An exception occurred while unmarshalling the specified XML product configuration file, 'D:\Server_Apps\PPM\conf\license\data\ProductConfigurations.xml', with message, 'null'.

I checked the ProductConfigurations.xml, then found that it is a zero byte file, and all other files in the data directory are zero byte file.

Contacted HP Support, still no solution.

Anybody encountered same issue?

Thanks!

Daniel

0 Likes
3 Replies
Erik Cole Acclaimed Contributor.
Acclaimed Contributor.

Re: Error when running the kLicenseInstall.sh after PPM 9.30 Upgrade

Daniel, do you have another ProductConfigurations.xml you could replace from another server? I just looked at all my environments, and the file is the same on all (despite different license counts) and is very simple, which suggests that it might mot be specific to a particular instance. Maybe that would solve it?

All the other files are zero-byte on mine, too.

0 Likes
DanielJiang Respected Contributor.
Respected Contributor.

Re: Error when running the kLicenseInstall.sh after PPM 9.30 Upgrade

Hey, Erik, is it possible to send me the ProductConfigurations.xml?

I wanted try this easy way too and asked the HP Support to provide me this file assuming it's a standard file, but he just keep ignoring this simple request....

 

0 Likes
Outstanding Contributor.. Loc_Nguyen_PPM Outstanding Contributor..
Outstanding Contributor..

Re: Error when running the kLicenseInstall.sh after PPM 9.30 Upgrade

Hi Daniel,

I had see that issue in the past, replace ProductConfigurations.xml fixed the issue.

I can't attached the file here, please ask Support engineer provide it for you.

Regards,

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.