Absent Member.. bzdafro Absent Member..
Absent Member..
233 views

Has any loaded data into the kenv_env_apps table?

Is it possible to load data into the kenv_env_apps table?  I need to add about 1000 entries.   I tried inserting some and it works, but it breaks a sequence counter KENV_ENV_APPS_S.   Thanks  

0 Likes
4 Replies
Absent Member.. Jim Esler Absent Member..
Absent Member..

Re: Has any loaded data into the kenv_env_apps table?

Each entry you add will need to be created for the specific database instance. The env_app_id will need to be set to the next value from the sequence. The environment_id will need to be set to the id of the appropriate environment in this database.

 

Passwords may also need to be reencrypted with the appropriate keys for this PPM instance. This could be done for the initial data load or afterwards, depending on what processes you have in place to manage them.

0 Likes
Established Member.. Utkarsh_Mishra
Established Member..

Re: Has any loaded data into the kenv_env_apps table?

Hi,

 

You can use HP provide out of the box package to insert the row in kenv_env_apps table.

 

Package Name is - KENV_ENV_APPS_TH

 

Procedure - KENV_ENV_APPS_TH.Process_Row

 

While calling this procedure, make sure that your event is INSERT.

 

i.e. p_event = 'INSERT'

 

This procedure take care of your env sequence; rest follow the steps suggested by JIM

Cheers..
Utkarsh Mishra

-- Remember to give Kudos to answers! (click the KUDOS star)
0 Likes
Absent Member.. leewil1 Absent Member..
Absent Member..

Re: Has any loaded data into the kenv_env_apps table?

After seeing Utkarsh's post I went ahead and tried using the KENV_ENV_APPS_TH.Process_Row procedure. This procedure call appeared to work successfully (no errors) and can see the new row in the database (table KENV_ENV_APPS).  However, upon entering PPM > Environment Workbench I can not see the app_code listed.  What piece am I missing?  Is a correspong report or refresh necessary? 

0 Likes
Absent Member.. leewil1 Absent Member..
Absent Member..

Re: Has any loaded data into the kenv_env_apps table?

Ok, I forgot 1 important command. Commit; This procedure does work. THANKS!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.