Absent Member.. Rash Absent Member..
Absent Member..
624 views

Header fields not available in status dependancies

Jump to solution

Hi All,

I face a wierd issue here:

One of my field in header sections are not avilable for me in status dependancies.

But i could see my field in front end, field,rule etc. But only in status i could see this field alone!!

Any one had come up with this issue? we are on 9.22!

 

Thanks,

Rash

0 Likes
1 Solution

Accepted Solutions
Absent Member.. Rash Absent Member..
Absent Member..

Re: Header fields not available in status dependancies

Jump to solution

Ya this was addressed by a manual process of removing the header type from the request and then add it again.But the impact we face is the status depandancies are rolled over to default which needs a configuring it again to the old one:(

 

Cheers,

Rash

0 Likes
4 Replies
Frequent Contributor.. hyllplan Frequent Contributor..
Frequent Contributor..

Re: Header fields not available in status dependancies

Jump to solution
Ive seen this too, some of the standard header fields are not available in status dep. If you want to hide them thrue the whole process just make them not visible on a field-level. If you want to hide them on a specific step you might be able to use a javascript rule, the build in, hide-something, check the manual.
Johan
0 Likes
Absent Member.. Rash Absent Member..
Absent Member..

Re: Header fields not available in status dependancies

Jump to solution

Ya this was addressed by a manual process of removing the header type from the request and then add it again.But the impact we face is the status depandancies are rolled over to default which needs a configuring it again to the old one:(

 

Cheers,

Rash

0 Likes
TorstenNeumann Absent Member.
Absent Member.

Re: Header fields not available in status dependancies

Jump to solution

I had the same problem today. The entries in table KCRT_FIELD_DEPENDENCIES were missing for the header field. As I did not want to reconfigure all header fields in status dependencies, I ran the following SQL to insert the missing entries:

 

insert into kcrt_field_dependencies (FIELD_DEPENDENCY_ID
,CREATION_DATE
,CREATED_BY
,LAST_UPDATE_DATE
,LAST_UPDATED_BY
,REQUEST_TYPE_STATUS_ID
,PARAMETER_SET_FIELD_ID
,HEADER_FIELD_FLAG
,REQUIRED_FIELD_FLAG
,DISABLED_FIELD_FLAG
,CLEAR_FIELD_FLAG
,RECONFIRM_FIELD_FLAG
,SOURCE_TYPE_CODE
,"SOURCE"
,VISIBLE_FIELD_FLAG)
select
  kcrt_field_dependencies_s.nextval FIELD_DEPENDENCY_ID
  ,sysdate CREATION_DATE
  ,1 CREATED_BY
  ,sysdate LAST_UPDATE_DATE
  ,1 LAST_UPDATED_BY
  ,rts.REQUEST_TYPE_STATUS_ID
  ,<<insert your parameter set field id here>> PARAMETER_SET_FIELD_ID
  ,'Y' HEADER_FIELD_FLAG
  ,'N' REQUIRED_FIELD_FLAG
  ,'N' DISABLED_FIELD_FLAG
  ,'N' CLEAR_FIELD_FLAG
  ,'N' RECONFIRM_FIELD_FLAG
  ,null SOURCE_TYPE_CODE
  ,null "SOURCE"
  ,'Y' VISIBLE_FIELD_FLAG
from
(select rts.request_type_status_id
  from kcrt_request_type_statuses rts
 where rts.request_type_id = (select request_type_id from kcrt_request_types_nls where request_type_name = '<<insert your request type name here>>')) rts

 

Please note that you need to insert your own PARAMETER_SET_FIELD_ID (from table KNTA_PARAM_SET_FIELDS_NLS) and request type name.

 

After you ran the SQL, you need to clear the cache:

 

<<PPM_HOME>>/bin/kRunCacheManager.sh A

 

After that, you should be able to configure your missing field in the workbench again.

Absent Member.. Scorpex Absent Member..
Absent Member..

Re: Header fields not available in status dependancies

Jump to solution

Hello TorstenNeumann,

 

I ran into this same issue today and ran your query which worked fine, the only issue seems to be that after running kRunCacheManager.sh A, I am still unable to see the field in the StatusDependencies in the workbench, I can see it fine when I check kcrt_field_dependencies.

 

Am I missing something or is the cache not clearing as it should.

 

**EDIT** After manually going into KCRT_FIELD_DEPENDENCIES and changing any parameter in the lines that were inserted with the Query the workbench finally was able to show the field, does anyone know why it took me commiting the changes manually instead of taking the sysdate for the LAST_UPDATE_DATE ?

 

Thanks!

Mig

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.