Highlighted
Absent Member.
Absent Member.
508 views

Issue in creating custom report

Jump to solution

Hi Team,

 

We are currently on PPM 7.5, SP7 and the OS is Windows 2003. We are currently in the process of building a new report for our client which is custom to their needs.

 

We have built the query and tested the same on our database before incorporating the call to the DB file containing the query. The issue here is that when we call the procedure the report id is not getting generated which in turn is throwing out the following error:

Run Report :
Oracle Error :ORA-06502: PL/SQL: numeric or value error: character string buffer
too small

 

As can be seen from above the Run report is blank, whereas it should have a report id. Checking the logs has not yielded any helpful information and also checking this site we did restart the server as recommended in one thread. 

 

If anyone has encountered this issues or can guide us on fixing this would be of great help.

 

Regards

 

Bharath

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

Thanks mdadok.

 

 

I resolved this issue and this was not related to PL/SQL. I had added a ';' in the query being passed on to the custom package which generates HTML Report and after removing this i was able to create reports.

View solution in original post

0 Likes
2 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hi Bharath,

 

This kind of error is produced from PL/SQL code if you have any string variable like VARCHAR, VARVCHAR2, CHAR etc. declared with length shorter than particular value that is going to be assigned to it. I would recommend verification of your customized PL/SQL code in order to catch all declaration of such strings and try to figure out which one might be too short. Debugging would be the best approach to get the solution.

 

Regards,

Maciek

Highlighted
Absent Member.
Absent Member.

Thanks mdadok.

 

 

I resolved this issue and this was not related to PL/SQL. I had added a ';' in the query being passed on to the custom package which generates HTML Report and after removing this i was able to create reports.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.