Outstanding Contributor.. Amishra Outstanding Contributor..
Outstanding Contributor..
131 views

Issue with Cost Rate Rollup service in 9.32

Hello There,

Since our upgrade to 9.32 we are seeing some performance issues with the Cost Rate update service. This service is runs every hour. Whenever we make changes to cost rates, it takes a lot of time for this service to run and complete successfully.  (Even for one cost rate change, the system takes upto 40 mins to complete)

We are working with HP internally to find out the root cause::

First recommendation was to change HEAVY_QUEUE_CONCURRENT_CONSUMERS and HEAVY_QUEUE_MAX_CONCURRENT_CONSUMERS parameters to 2 from current setting of 1. Since setting these parameters to 2 can result in JVM overflow errors.

Second approach is to turn off FM_COST_ENABLE_AUDIT parameter in PPM. This parameter when set true, inserts multiple rows in PPM_FM_COST_AUDIT and PPM_FM_COST_AUDIT_RATE tables and the table grows enormously.

I still feel, that there has been an overall impact on the Cost Rate Update Service in 9.32 as compared to 9.22.

Altough this case is still being worked on with HP, thought if any one of you folks have seen or experienced any such issue. 

 

Please advise.

Thank you in Advance!

Ajay

Regards,
Ajay Mishra
0 Likes
2 Replies
Absent Member.. DomPPM Absent Member..
Absent Member..

Re: Issue with Cost Rate Rollup service in 9.32

Hello Ajay,

 

I hope you are doing great today.

 

I have searched a little about this, if you are reffering to the "Cost Rollup Service, I believe you would like to check this QCCR that I found: 

 

https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/LID/QCCR1L60618

 

You can register to it to receive notifications any time R&D makes any update in this QCCR to see the progress of the same.

 

Hope this helps you out!

 

Best regards,

Dominic C

Outstanding Contributor.. Amishra Outstanding Contributor..
Outstanding Contributor..

Re: Issue with Cost Rate Rollup service in 9.32

Thank you for the link Dominic. I have registered. 

It is not only when the records are high, even when you have 5 odd records it takes significant amount of time. 
Turning off FM_COST_ENABLE_AUDIT parameter helps only if you have 1-2 change per hour.
For the time being we are living with this work-around.


Thanks again.

Regards,
Ajay Mishra
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.