Absent Member.. siva_narayana Absent Member..
Absent Member..
199 views

Issue with ksc_set_env

Hi

 

I am trying to set source and destination environment dynamically through the below script in a workflow execution script. During the execution of the last line I am getting the error(Execution log attached).  Just want to understand how exactly ksc_set_env is used and if I am doing anything wrong as far as syntax is concerned. Appreciate any guidance.

 

ksc_itg_run_sql QUERY_STRING="SELECT environment_id FROM kenv_environments where environment_name='[VP.P_SVN_SERVER]'"
ksc_set S_ID=[SQL_OUTPUT]
ksc_itg_run_sql QUERY_STRING="SELECT environment_id FROM kenv_environments where environment_name='[VP.P_PPM_ENVIRONMENT]'"
ksc_set D_ID=[SQL_OUTPUT]
ksc_set_env SOURCE_ENV_ID="[S_ID]" DEST_ENV_ID="[D_ID]"

 

 

I am even tried hardcoing the environment, but even that gave the same error. 

 

 

Thanks

Shankar

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.