KaranMalhotra Absent Member.
Absent Member.

PPM 9.22 - Error running reports - bad UTF

We have just upgraded our PPM system from 9.14 to 9.22. After the upgrade, most of the reports are not running.


They are erroring out with the same error message:

Error retrieving environment information

bad UTF


I can see at the server reports folder, that PPM was able to create the report (the .html output file exists).


But it is still throwing this exception in the log. I have read through previously posted forum articles, and have:

- changed the Stream Encoding to UTF-8 / US-ASCII for both the server and client areas;

- 'checked' the environment record - success;

- updated the server.conf file with I18N parameters with both UTF-8 and US-ASCII values.

- recompiled JSPs

- ran kUpdateHtml

- ran kKeyGen


Currently, all env and conf parameters are set to UTF-8; and the html output file also shows UTF-8.

Everything checks out but the error message is not going away.


Any help would be really appreciated!




ERROR :CommandRunner for com.kintana.core.server.execution.CLLocalExecCommand Batch ID: 66707:com.kintana.core.executions.commands.localExec:2014/08/11-00:50:34.755 CDT: Unexpected exception occurred running ksc_local_exec:

java.lang.RuntimeException: bad UTF

        at com.kintana.sc.security.ElGamalAlgorithm.convertUTF8ToString(ElGamalAlgorithm.java:284)

        at com.kintana.sc.security.ElGamalAlgorithm.decrypt(ElGamalAlgorithm.java:215)

        at com.kintana.sc.security.ElGamalAlgorithm.decrypt2(ElGamalAlgorithm.java:389)

        at com.kintana.core.util.PasswordManager.decryptElGamal(PasswordManager.java:428)

        at com.kintana.core.util.PasswordManager.decrypt(PasswordManager.java:133)

        at com.kintana.core.util.PasswordManager.decrypt(PasswordManager.java:150)

        at com.kintana.core.util.FileUtils.getLocalhost(FileUtils.java:438)

        at com.kintana.core.server.execution.CLLocalExecCommand.execute(CLLocalExecCommand.java:491)

        at com.kintana.core.server.execution.CommandRunner.run(CommandRunner.java:120)

        at java.lang.Thread.run(Thread.java:745)


3 Replies
Acclaimed Contributor.. dirkf Acclaimed Contributor..
Acclaimed Contributor..

Re: PPM 9.22 - Error running reports - bad UTF

Hi Karan,


there's currently a case under investigation in the US-region for a seemingly identical issue.

Besides that, I couldn't find a case that would relate to this issue by upgrade, only by cloning instances, therefore I don't want to use investigation done there.

Can you please confirm that the open case in the US is NOT your case - in which case I would suggest that you do open a case and reference the case ID that is already being investigated.

Please PM me and I will let you know case and incident that is under investigation so you can add this to a potential new case with Support.


Alternatively, I could update this thread when a solution is found for that case and if it is not yours.


I would like your confirmation beforehand whether it's your case or not.


Thanks and best regards,


KaranMalhotra Absent Member.
Absent Member.

Re: PPM 9.22 - Error running reports - bad UTF

Hi Dirk,


Thanks for your response.


No, I have not opened a case with HP Support for this issue.


Let me give you a little background about my issue, that I missed in the original post. I took a copy of the PROD (9.14) database and put it over the DEV (9.14) schema. Then, I upgraded DEV from 9.14 to 9.22.0002 using the PPM Upgrade packs.


Today, I ran the kKeyGen.sh script again, in hopes that something might change (based on what I read on forums threads like this one). The script executed successfully and the error has now changed.


Error retrieving environment information

Text doesn't appear to be necoded or there is an encryption key mismatch


The environment record (KINTANA_SERVER) still checks out with all green lights. This is currently impacting a huge number of reports. All of them use ksc_local_exec.




Acclaimed Contributor.. dirkf Acclaimed Contributor..
Acclaimed Contributor..

Re: PPM 9.22 - Error running reports - bad UTF

Hi Karan,


I've had a look at the data and the changed environment error looking different now points elsewhere.

I'm a bit confused as to why the reports are working but not logging failure.


I've found some hints but they are all a bit vague, so please exercise with caution.


The most promising one to me seems to be to use kConfig.sh to enter the configuration and retype and save the DB- and other passwords for the users, so the correct encryption keys are used.



java.lang.RuntimeException: Text doesn't appear to be encoded or there is an encryption key mismatch.
at com.kintana.sc.security.ElGamalAlgorithm.decode(ElGamalAlgorithm.java:371)


After exiting kConfig run kUpdateHtml again.


Let me know if that helps.

Best regards,


The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.