Highlighted
Contributor.
Contributor.
131 views

PPM Support Tip: Unknown Error using Web Services caused by missing Rule value

A new KCS article was published: KM00570071

 

 

When trying to create requests via Web Service calls, an unknown error is shown

 

Client is trying to create Requests via Web Services. It succeeds with certain values but fails with others.

 

- <soapenv:Fault>
  <faultcode>UNKNOWN</faultcode>
  <faultstring>An error occured when creating a request-Error 2: Error validating value "HP - Relationship Management" for field REQD.HP_APPLICATION_AREA: no valid data was found for autocomplete. Error 2: Error validating value "RM_L3" for field REQ.ASSIGNED_TO_GROUP_NAME: no valid data was found for autocomplete.</faultstring>
- <detail>
 

A value for a Rule was null when one should be provided.

Defect QCCR1L52427
Fixed in 9.2 version.
Scehduled to be fixed in 9.14.0008 (check the Release Notes when released).
Workaround: Ensure Rules' Fields that require a value are being provided with a value.

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Labels (1)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.