Our vBulletin migration is complete.
Welcome vBulletin users! All content and user information from the Micro Focus Forums (vBulletin) site has been migrated to this site. READ MORE.
Highlighted
mike_se Contributor.
Contributor.
210 views

PPM Support Tip: "Before Save" Rule, Table Component Token causes "failed to execute" error

A new KCS article was published: KM00465433

 

 

When using "Before Save" Rule, Table Component "Total" Value causes "failed to execute" error 


Demand Management issue - Defect with the Table Component Token

Error when trying to use "Before Save" Rule with a Table Component.

Example of error seen in browser:
Rule 2 - 'add it up again' failed to execute.



When the User is not "admin", they cannot use "Before Save" Rule to access the Table Component (TC) token.

If the Rule depends on another field which is not a TC, for example add a field 'number1' with token 'NUMBER1', and change the Rules SQL to "select [REQD.P.NUMBER1], [REQD.VP.NUMBER1] from dual", then there is no issue.

The Workaround is either:
1) Use "On Field Change" Rule instead of "Before Save" Rule
or
2) Save the TC Total Value to another Field with "On Field Change" Rule, then use "Before Save" Rule to fetch the Value in that temp field

 


Defect QCCR1L51879

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Labels (1)
0 Likes
2 Replies
pepdwill Honored Contributor.
Honored Contributor.

Re: PPM Support Tip: "Before Save" Rule, Table Component Token causes "failed to exec

Are there any known instances of this error occurring for Page Load rules also?

 

I have a new page load rule which is populating a field based on the Total of a table component field.  The rule is working and I can see the field populating correctly, but when I try to save the request I receive this failed to execute message referencing the rule # (along with a GUID code).

 

This is especially strange because it is an on page-load rule, not a before save rule.

 

Any thoughts?

 

 

 

0 Likes
Established Member.. JoaoCosta
Established Member..

Re: PPM Support Tip: "Before Save" Rule, Table Component Token causes "failed to exec

Hi,

We were facing the same issue with a "On-Save" rule, to copy the column aggregated values to a request field.
And we noticed that it only happened for a sub-set of users (like "admins" as mentioned in one of the above posts).

We figured it out that it was because another unrelated field had "Edit Security" linked to a specific Security Group.

So for users not in that security group:
- Normal saves with the rule disabled: worked
- Normal saves with the rule enabled: failed
- Normal saves with the rule enabled and without the Edit restriction on the other unrelated field: worked

We end up removing security from the other field.

Kind regards,
João Costa (InovaPrime)

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.