Super Contributor.. JHarris941 Super Contributor..
Super Contributor..
813 views

Package workflow issue

Jump to solution

Hello All,

 

I am trying to create a package workflow with one decision step routing to multiple execution steps. For some reason when I select an environment from the decision step, it does not make that execution eligible. I am using a drop down list validation for the environment selection and all the execution steps route back to the decision step after it is completed. I have the proper security group on each step to make sure I can take action on the step.  I attached a picture of the workflow im creating. Anyone have any idea why this is happening? 

 

Thanks,

Jajcen

0 Likes
1 Solution

Accepted Solutions
Super Contributor.. JHarris941 Super Contributor..
Super Contributor..

Re: Package workflow issue

Jump to solution

Jason,

 

I got it to work! I kept your suggestion to simplifiy the "code" for the transtion from 1-8. Once I did that I changed the "Decision" field to "One" instead of "At Least One". Looks like that did the trick. Thanks guys for your help.

 

Jajcen

0 Likes
11 Replies
Jason Nichols K Absent Member.
Absent Member.

Re: Package workflow issue

Jump to solution
Does the graphical view of the workflow show that the transition has progressed to the appropriate step?
0 Likes
Super Contributor.. JHarris941 Super Contributor..
Super Contributor..

Re: Package workflow issue

Jump to solution

No it doesn't...it just shows that the first step "Migrate To?" as the active step after I select an instance to migrate to.

0 Likes
Jason Nichols K Absent Member.
Absent Member.

Re: Package workflow issue

Jump to solution

Can you attach a screen shot of the Decision Step Source and the Validation used on that step source?  A Workflow Detail Report would work as well with Show Transitions and Show Valid Results checked to include.

Super Contributor.. JHarris941 Super Contributor..
Super Contributor..

Re: Package workflow issue

Jump to solution

Here is the screenshots...all executions route back to "Migrate To?".

0 Likes
Jason Nichols K Absent Member.
Absent Member.

Re: Package workflow issue

Jump to solution
This shouldn't be affecting the other transition lines, but the Development Manual does specify not to use any special characters except the underscore (_) in the CODE portion of Validations.

Does the Close transition work?

If you set one of the transition lines to All Results or Other Results, do you get any movement?
0 Likes
Super Contributor.. JHarris941 Super Contributor..
Super Contributor..

Re: Package workflow issue

Jump to solution

The Close transition does not work currently. Right now all the executables are set to  "All Results" when completed. Its really strange. I just went into another test pkg with the same workflow and the execute environment was eligible. Then, it went back to "Migrate To?" just like I want when I bypassed as successful. Now, when I select a new instance and move it forward, nothing is eligible again. 

Weird.

0 Likes
Jason Nichols K Absent Member.
Absent Member.

Re: Package workflow issue

Jump to solution
I was suggesting you change one of the transition lines from the decision step to one of the execution steps to have "All Results" or "Other Results" to see if that will transition when you select a value.

The next step would be to create a new Decision Step Source and Validation with the Code/Values as 1,2,3,4,5,6,7 to see if these simple values will transition correctly.
Super Contributor.. JHarris941 Super Contributor..
Super Contributor..

Re: Package workflow issue

Jump to solution

Thanks Jason...I tried both of your suggestions and they did not work. It still shows "Eligible" grayed out when I select an instance to migrate to.

0 Likes
Jason Nichols K Absent Member.
Absent Member.

Re: Package workflow issue

Jump to solution

Can I see a screen shot of the Security Tab on the Decision step?

0 Likes
Super Contributor.. JHarris941 Super Contributor..
Super Contributor..

Re: Package workflow issue

Jump to solution

Jason,

 

I got it to work! I kept your suggestion to simplifiy the "code" for the transtion from 1-8. Once I did that I changed the "Decision" field to "One" instead of "At Least One". Looks like that did the trick. Thanks guys for your help.

 

Jajcen

0 Likes
Jason Nichols K Absent Member.
Absent Member.

Re: Package workflow issue

Jump to solution
Happy to help and I'm glad it's working!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.