Absent Member.. thePITman Absent Member..
Absent Member..
286 views

SQL Validation not updating values in drop-down field

Jump to solution

I have a SQL validation that drives the list of values in an drop-down field on a PPM request. However, when a new item becomes available for the list, it is not appearing as an option when selecting the field on the request.

If I run the validation's SQL in the database or in the PPM system tools, the new item shows up. in the query results But the item still does not appear when viewing the list of options inside the request when I drop down the menu.

If I am in Search > Requests and want to filter on the field, the new option appears. But it does not appear when I am on the request trying to populate the field with the new value.

Is this an issue with the Drop-down list vs. the Auto-Complete list? I have an Auto-Complete that seems to be working fine in both the Search screen AND on the request itself.

0 Likes
1 Solution

Accepted Solutions
Respected Contributor.. Ariel_V_PPM Respected Contributor..
Respected Contributor..

Re: SQL Validation not updating values in drop-down field

Jump to solution

Hello,

In several cases the reason can be related with some cache issues but is important to check other things,  

You can check the rules and validation configurations, for example:

When you create an Org Unit using "Department” type. It does not means that it will display in the Org Unit Department field, If you want to display the same name in that field, you need to manually add a new validation value in the workbench Steps to perform: Go to Workbench > Configuration > Validation > Open a validation called: "PPM - Department - Enabled" Then click on Add a new Value, and use the name of your new Org Unit. In this way, the validation for the “Department” field will also display the new value

You can perform the below steps and see the results. If this doesn’t help, I recommend open a new case with support team, because the issue can be produced by different scenarios.

1) Stop the server.

2) Delete tmp and work and run kJSPCompiler.sh. Delete the two directories \server\\tmp and \server\\work

Note: Repeat for all servers (nodes)

Note: Do not back these directories up as they will be re-created when the PPM instance is started.

3) Go to PPM_HOME/server/SERVER_NAME/log and re-name the serverLog.txt file. This will allow for a clean log to review.

Note: Repeat for all servers (nodes)

4) Restart server

5) Run kRunCacheManager.sh -A (clear all cache).

 

I hope this information can help with your issue,

Best Regards!

3 Replies
Respected Contributor.. Ariel_V_PPM Respected Contributor..
Respected Contributor..

Re: SQL Validation not updating values in drop-down field

Jump to solution

Hello,

In several cases the reason can be related with some cache issues but is important to check other things,  

You can check the rules and validation configurations, for example:

When you create an Org Unit using "Department” type. It does not means that it will display in the Org Unit Department field, If you want to display the same name in that field, you need to manually add a new validation value in the workbench Steps to perform: Go to Workbench > Configuration > Validation > Open a validation called: "PPM - Department - Enabled" Then click on Add a new Value, and use the name of your new Org Unit. In this way, the validation for the “Department” field will also display the new value

You can perform the below steps and see the results. If this doesn’t help, I recommend open a new case with support team, because the issue can be produced by different scenarios.

1) Stop the server.

2) Delete tmp and work and run kJSPCompiler.sh. Delete the two directories \server\\tmp and \server\\work

Note: Repeat for all servers (nodes)

Note: Do not back these directories up as they will be re-created when the PPM instance is started.

3) Go to PPM_HOME/server/SERVER_NAME/log and re-name the serverLog.txt file. This will allow for a clean log to review.

Note: Repeat for all servers (nodes)

4) Restart server

5) Run kRunCacheManager.sh -A (clear all cache).

 

I hope this information can help with your issue,

Best Regards!

Highlighted
Absent Member.. thePITman Absent Member..
Absent Member..

Re: SQL Validation not updating values in drop-down field

Jump to solution

Thank you very much for the quick response. I had our DBA run these steps this morning in a DEV environment, and they appear to have worked (new items are showing up in the drop-down). We will be doing this in Production in the coming days. I will post an update once we know it worked.

Is this something where the cache may have gotten too full and didn't allow things to be updated? Or will this happen every time a new item is made available for a drop-down? I guess I will find out. 🙂

0 Likes
Respected Contributor.. Ariel_V_PPM Respected Contributor..
Respected Contributor..

Re: SQL Validation not updating values in drop-down field

Jump to solution

Hello!

I hope you are doing fine,

I think is a cache issue.

Those steps are recommended done one time every month. It is good practice to keep clean and free of problems such servers.
I am glad that my recommendation it was useful.

Have a nice day!

Best Regards.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.